Forums développeurs windev
[Windev 20] connexion à une bdd hfsql c/s via windev mobile android - Version imprimable

+- Forums développeurs windev (http://tunidev.net)
+-- Forum : Forums Développeurs WINDEV (http://tunidev.net/Forum-Forums-D%C3%A9veloppeurs-WINDEV)
+--- Forum : Forum windev 11 & plus récentes (http://tunidev.net/Forum-Forum-windev-11-plus-r%C3%A9centes)
+--- Sujet : [Windev 20] connexion à une bdd hfsql c/s via windev mobile android (/Thread-Windev-20-connexion-%C3%A0-une-bdd-hfsql-c-s-via-windev-mobile-android)



connexion à une bdd hfsql c/s via windev mobile android - jupeton - 03-07-2018

bonjour
je suis à la recherche d'un moyen d'accès rapide à ma bdd hfsql c/s. le code que j'utilise est lourd à la connexion. VOICI LE CODE...
Code :
HLitRecherche(CompteAccès,IDCompteAccès,1)
SI HTrouve(CompteAccès) ALORS
    // Description de la connexion
    MaConnexion..Utilisateur = "LOGIN"
    MaConnexion..MotDePasse = CompteAccès.Secret//    
MaConnexion..Serveur = CompteAccès.IPAdressPoste+":"+CompteAccès.PortReseau
    MaConnexion..BaseDeDonnées = CompteAccès.BDD
    MaConnexion..Provider = hAccèsHFClientServeur
    MaConnexion..Accès = hOLectureEcriture
    MaConnexion..InfosEtendues = "Infos étendues"
    //MaConnexion..OptionsCurseur = hCurseurClient
    
    //HChangeConnexion("*",MaConnexion)
    HPasse("*","@@@@@@@@@@@@")
    Patienté1("Tentative de connexion au serveur")
    SI HOuvreConnexion(MaConnexion) ALORS
        bConnect = Vrai
        Patienté1()
OuvreFenêtreMobile(FEN_Accueil)
    FIN
    
FIN