Forums développeurs windev
xls ou xlsx - Version imprimable

+- Forums développeurs windev (http://tunidev.net)
+-- Forum : Forums Développeurs WINDEV (http://tunidev.net/Forum-Forums-D%C3%A9veloppeurs-WINDEV)
+--- Forum : Forum windev 11 & plus récentes (http://tunidev.net/Forum-Forum-windev-11-plus-r%C3%A9centes)
+--- Sujet : xls ou xlsx (/Thread-xls-ou-xlsx)



xls ou xlsx - XLGUY - 03-04-2018

Bonjour à tous,

Je bute sur ce problème....
Je veux lire dans un fichier excel (ok pas de problème)
mais le problème est l'ouverture de ce fichier car
j'ai une variable pour le chemin du fichier
et une pour le nom
mais si le fichier est sauvegardé sous extension xls ou xlsx, comment indiquer dans xlouvre le nom avec l'extension correcte
sans la connaitre d'avance ?
Merci à tous
Bonne journée
XLGuy


RE: xls ou xlsx - fouedusa - 03-04-2018

Bonjour;

Code :
IdFichierXLS est un entier
sNomFichier est une chaîne = "Test"

IdFichierXLS = xlsOuvre(ComplèteRep(fRepExe()) + sNomFichier +".XLS")

SI IdFichierXLS <> -1 ALORS
    Info("Fichier XLS Trouvé")
    xlsFerme(IdFichierXLS)
SINON
    IdFichierXLS = xlsOuvre(ComplèteRep(fRepExe()) + sNomFichier +".XLSX")
    SI IdFichierXLS <> -1 ALORS
        Info("Fichier XLSX Trouvé")
        xlsFerme(IdFichierXLS)
    SINON
        Info("Erreur d'ouverture du fichier voir avec la fonction ErreurInfo")
    FIN
FIN

Bon Dev.

Remarque : voir la fonction fselecteur


RE: xls ou xlsx - XLGUY - 03-04-2018

(03-04-2018, 10:38 AM)fouedusa a écrit : Bonjour;

Code :
IdFichierXLS est un entier
sNomFichier est une chaîne = "Test"

IdFichierXLS = xlsOuvre(ComplèteRep(fRepExe()) + sNomFichier +".XLS")

SI IdFichierXLS <> -1 ALORS
    Info("Fichier XLS Trouvé")
    xlsFerme(IdFichierXLS)
SINON
    IdFichierXLS = xlsOuvre(ComplèteRep(fRepExe()) + sNomFichier +".XLSX")
    SI IdFichierXLS <> -1 ALORS
        Info("Fichier XLSX Trouvé")
        xlsFerme(IdFichierXLS)
    SINON
        Info("Erreur d'ouverture du fichier voir avec la fonction ErreurInfo")
    FIN
FIN

Bon Dev.

Remarque : voir la fonction fselecteur

Bonjour Fouedusa
Merci pour le code, j'avais pensé faire une condition avec les 2 extensions mais je croyais qu'il y avait une solution sans tous ça... Smile Tongue
A+ et merci
XLGUY