Forums développeurs windev
Ouvrir et traiter plusieurs fichiers TXT - Version imprimable

+- Forums développeurs windev (http://tunidev.net)
+-- Forum : Forums Développeurs WINDEV (http://tunidev.net/Forum-Forums-D%C3%A9veloppeurs-WINDEV)
+--- Forum : Forum windev 11 & plus récentes (http://tunidev.net/Forum-Forum-windev-11-plus-r%C3%A9centes)
+--- Sujet : Ouvrir et traiter plusieurs fichiers TXT (/Thread-Ouvrir-et-traiter-plusieurs-fichiers-TXT)



Ouvrir et traiter plusieurs fichiers TXT - Finereader - 26-04-2017

Bonjour tout le monde,

j'ai un souci et je me torture la tête à trouver une solution, en vain..

En gros : mon code va faire un fListeFichier d'un dossier pour ne cibler que les fichiers .TXT
Ensuite il est "supposé" ouvrir chaque fichier, extraire la seule ligne qu'il contient, et la renseigner dans un fichier base.fic

Mon besoin : Ouvrir chaque fichier résultant de mon fListeFichier, extraire la ligne de texte via un fLitLigne (ou fChargeTexte) puis l'enregistrer dans mon fichier base.fic

Mon problème : je suis incapable de récupérer le nom de chaque fichier (via mon fListeFichier) pour ouvrir chaque fichier texte dans une boucle..  Apparemment je peux le faire via une procédure locale, mais comment la construire....?

Si jamais vous aviez la solution..?

Code :
sAjoutLigne, sImport, sResListeFichier sont des chaînes
sFichierExiste est une chaîne = "C:\Dossier\*.txt"

sResListeFichier = fListeFichier("C:\Dossier\*.TXT",frNonRécursif)

POUR TOUTE CHAÎNE sAjoutLigne DE sResListeFichier SEPAREE PAR RC
    
    // C'est à partir de la qu'il me manque le code pour ouvrir chaque fichier texte, un par un
    
    sImport = HAjoute(Base)



RE: Ouvrir et traiter plusieurs fichiers TXT - Samifred - 27-04-2017

Bonjour,

Dans un premier temps il faut remplir une table avec le chemin et le nom du fichier TXT...

POUR TOUTE CHAINE...
TableAjoute(TableTXT, sAjouteLigne)  //La table peut être hors écran ou hors fenêtre
FIN

Dans un deuxième temps...

Lire chaque ligne de tableTXT en ouvrant et fermant les fichiers TXT.

POUR i=1_A_ TableTXT..Occurrence

fOuvre("Le fichier TXT")

fLit() ou fLitLigne()

Hajoute("Dans le fichier HF") //La ligne lue

fFerme("Le fichier TXT")

FIN

Et finalement afficher le contenu du fichier HF dans une seconde table (fichier ou mémoire).

Pour les détails l'aide est bien fournie.

Cordialement


RE: Ouvrir et traiter plusieurs fichiers TXT - Finereader - 27-04-2017

Samifred,

Dans un premier temps, merci pour ton aide..

Après avoir un peu galéré j'ai fini par comprendre mon erreur et l'ai corrigé, c'est mieux, pas tout à fait ça, mais j'y arrive petit à petit :-)


RE: Ouvrir et traiter plusieurs fichiers TXT - Samifred - 28-04-2017

...

Tu peux aussi créer une vue ou un tableau dynamique...

Bon dev.