Forums développeurs windev

Version complète : [RÉSOLU] exporte une table en fichier texte ?
Vous consultez actuellement la version basse qualité d’un document. Voir la version complète avec le bon formatage.
Bonjour à tous,
je m'arrache les cheveux ........
j'ai une table contenant environ 500 titres de films !
un bouton pour copier le liste de ces films dans un fichier texte !
jusque là, tout va bien ! la liste de ces 500 films est crée
dans une autre table, contenant la liste des genres de ces films, j'ai le même bouton avec le même code !
environ 50 genres !
la table ne m'affiche que 19 lignes, et le code ne me copie que ces 19 lignes !
pourquoi cela fonctionne dans une liste de 500 fims, et pas dans une liste de 50 genres ?
merci de votre aide
Bonjour,

Toujours publier le code utilisé !

Quel code utilises-tu ? :lol:
oups ! désolé !

SI Table..Vide = Vrai ALORS
Erreur(" Votre Table est Vide ! Exportation Impossible !")
SINON
fCrée("Liste des Genres Dvd.txt")
v_nomFichier est une chaîne
numFic est un entier
v_indice est un entier

v_nomFichier =fSélecteur("", "", "Sélectionnez un fichier...", "Liste des Genres Dvd (*.txt)"+TAB+"*Liste des Genres Dvd.txt", "txt", fselCrée)
SI v_nomFichier <> "" ALORS
numFic= fOuvre(v_nomFichier,foCréation)
SI numFic <> -1 ALORS
// sauvegarde des table
POUR v_indice = 1 A TableOccurrence(Table)
fEcritLigne(numFic,Table.Genre[v_indice])
FIN
FIN
FIN
FIN

le même code fonctionne avec la liste des 500 films
Essayes comme ceci... (moi je commence toujours par la fin mais à partir du fichier)

Code :
SI Table..Vide = Vrai ALORS
Erreur(" Votre Table est Vide ! Exportation Impossible !")
SINON
fCrée("Liste des Genres Dvd.txt")
v_nomFichier est une chaîne
numFic est un entier
v_indice est un entier

v_nomFichier =fSélecteur("", "", "Sélectionnez un fichier...", "Liste des Genres Dvd (*.txt)"+TAB+"*Liste des Genres Dvd.txt", "txt", fselCrée)
SI v_nomFichier <> "" ALORS
numFic= fOuvre(v_nomFichier,foCréation)
SI numFic <> -1 ALORS
// sauvegarde des table
POUR v_indice = TableOccurrence(Table) _A_ 1 PAS -1
fEcritLigne(numFic,Table.Genre[v_indice])
FIN
FIN
FIN
FIN
Merci Monsieur SamiFred,
mais j'ai toujours le même résultat ! 19 lignes !
C'est bizarre...

Essayes de lire directement le fichier et c'est plus rapide...

HLitDernier()
TANTQUE PAS HEndehors()
fEcritLigne(....
HLitPrécédent()
FIN
merci SamiFred, c'est ce que je viens de faire et ça marche comme ça !
j'aurais du y penser avant de poster cette question !
bonne journée à toi