Forums développeurs windev

Version complète : afficer les infos d'une base de donne pré-rempli
Vous consultez actuellement la version basse qualité d’un document. Voir la version complète avec le bon formatage.
Pages : 1 2 3

faloudja

Bonjour
je suis debutant en windev
je viens demander de l'aide au plus expérimenter

j'ai deux base de donnees nomme
Français et Anglais
id_motF | id_motA
MOTF | MOTA

J'ai une fenetre Principale
un champ de saisief et un autre champ de saisieA
ET un bnt TRADUIRE
Quand Je saisie le mot (salut )dans saisieF il me donne resultat dans saisieA (hello)
en cliquant sur le BTN traduire.

Merci d'avance de m'aider

<!-- e --><a href="mailtoConfusediehabib@yahoo.fr">siehabib@yahoo.fr</a><!-- e -->
bon dev

faloudja

Bonjour

si je creer une fenetre nommer affiche

en programmant
initialisation du projet
HCréationSiInexistant(français,Anglais)


Declaration globale
PROCEDURE Affiche(gsMot)

Initialisation Affiche
HLitRecherchePremier(françcais,Anglais,gsMot)
SI HTrouve(français,Anglais) ALORS
Affiche..Plan = 1
SINON
Affiche..Plan = 2
Libellé1 = "Le Mot " + gsMot + ", est introuvable !"
FIN

MERCI de m'aider SVP
<!-- e --><a href="mailtoConfusediehabib@yahoo.fr">siehabib@yahoo.fr</a><!-- e -->

bon dev
Pourquoi tu utilises deux fichiers ?... un fichier est suffisant !

Nom fichier: Mots
Rubrique 1: mot_F (Clé unique)
Rubrique 2: mot_A (Clé unique)

//Mot à traduire
MotRecherche = "Bonjour"

//Sélecteur de traduction
1 = "Français vers anglais" 2 = "Anglais vers français"

//Sélection ok..
Sélecteur1 = 1

SELON Sélecteur1
CAS 1
// Recherche mot en français vers anglais
HLitRecherche(Mots, mot_F, MotRecherche)
SI HTrouve(Mots) ALORS
Libellé = Mots.mot_A
FIN

CAS 2
// Recherche mot en anglais vers français
HLitRecherche(Mots, mot_A, MotRecherche)
SI HTrouve(Mots) ALORS
Libellé = Mots.mot_F
FIN
FIN

//Mot affiché
Hello

faloudja

Bonjour Mr Samifred

de ta reponse si vite

je refais ma base et je reviens

merci d'avance de m'aider

bon dev

faloudja

Bonjour Mr Samifred

J'ai bien refais la base de donne

mais ou placer ces codes

dans mon btn traduction ou créer un sélecteur et les y placer


merci de m'aider

bon dev
Dans le code clic du bouton "Traduction"...
-----------------------------------------------------
// Code clic bouton...
SELON Sélecteur1
CAS 1
// Recherche mot en français vers anglais
HLitRecherche(Mots, mot_F, MotRecherche)
SI HTrouve(Mots) ALORS
Libellé = Mots.mot_A
FIN

CAS 2
// Recherche mot en anglais vers français
HLitRecherche(Mots, mot_A, MotRecherche)
SI HTrouve(Mots) ALORS
Libellé = Mots.mot_F
FIN
FIN
------------------------------------------------------

Il faut aussi... pour le traitement de traduction

un champ de saisie... //pour saisir le mot à traduire
un champ Sélecteur.... //pour sélectionner le type de traduction
un champ libellé... //pour afficher le résultat

-----------------------------------------------------------

Une fiche pour saisir les mots Français et Anglais

--------------------------------------------------------------
...

faloudja

Bonjour
Mr Samifred

Fichier avec table ou sans table ( fiche simple avec btn valider (qui va stocker ou les infos valider sans la table)


merci de m'aider

<!-- e --><a href="mailtoConfusediehabib@yahoo.fr">siehabib@yahoo.fr</a><!-- e -->

bon dev
Re..

Je pense qu'avec une table se sera plus simple, déjà pour visionner et gérer les données.

...

faloudja

Bonjour Mr Samifred

je veux remplir moi meme ma base

et s'il ya une procedure de faire un appel des mes donnes et de les afficher

merci de m'aider

bon dev
<!-- e --><a href="mailtoConfusediehabib@yahoo.fr">siehabib@yahoo.fr</a><!-- e -->

faloudja

Bonjour Mr Samifred

C'est tres propre,C'est tres propre,C'est tres propre

merci beaucoup ,merci beaucoup,merci beaucoup

j'ai écarte l'option fiche et table
et remplir la base moi meme et ça passe tres bien


J'aimerai savoir s'il un moyen de cacher l'analyse dans programme file
ou de crypter mon analyse svp.


MERCI ENCORE
BON DEV
Pages : 1 2 3