Forums développeurs windev

Version complète : Affichage de tous les donnes sur ma table
Vous consultez actuellement la version basse qualité d’un document. Voir la version complète avec le bon formatage.
Pages : 1 2

faloudja

Bonjour
je viens demande de l'aide
au plus expérimenter

j'ai une fenetre nommer Depart et une autre fichier
j'ai une base de donne (produit)
une table_produit

id_produit cle unique
nomP
gth
Indication
forme
posologie
prixPublic


code nouveau
Ouvre(fiche,"Nouveau")
TableAffiche(Table_Produit,taCourantPremier)

code modifier
SI TableOccurrence(Table_Produit) = 0 OU Table_Produit = -1 ALORS RETOUR
Ouvre(fiche,"Modifier")
TableAffiche(Table_Produit,taCourantPremier)

code supprimer
SI TableOccurrence(Table_Produit) = 0 OU Table_Produit = -1 ALORS RETOUR
SELON OuiNon("Supprimer cette ligne ?")
CAS Oui
TableSupprime(Table_Produit,Table_Produit)

CAS Non
RETOUR
FIN


code de chemin photo
sSel est une chaîne
sSel = fSélecteurImage("", "Fichier.jpg", "Sélectionner une image","JPEG (*.JPG)"+ TAB +"*.jpg"+ RC +"BMP (*.BMP)"+ TAB +"*.bmp"+ RC +"PNG (*.PNG)"+ TAB +"*.png"+ RC +"GIF (*.GIF)"+ TAB +"*.gif")
SI sSel<>"" ALORS
fCopieFichier(sSel,fRepEnCours()+"\Photos\"+ExtraitChaîne(sSel,1,"\",DepuisFin),frConfirmer)
CheminPhoto = fRepEnCours()+"\Photos\"+ExtraitChaîne(sSel,1,"\",DepuisFin)
Photo = CheminPhoto
FIN

code du btn valide
EcranVersFichier()
SELON gsAction
CAS "Nouveau"
HAjoute(Produit)


CAS "Modifier"
HModifie(Produit,hNumEnrEnCours)
FIN

Ferme()

dans initialisation de valide
gsAction
declaration global de fiche
procedure fichier gsAction


quand je valide tous les donnes ne s'affiche pas et les images aussi



merci de m'aider
<!-- e --><a href="mailtoConfusediehabib@yahoo.fr">siehabib@yahoo.fr</a><!-- e -->
Bonsoir,

Dans la fiche, est-tu sûr que les champs sont tous liés au rubriques du fichier de l'analyse ?

faloudja

Bonsoir
et merci de repondre aussi vite

oui les elles sont lié

d'autres apparaissent dans ma table sauf forme ,posologie , prix et image

merci de m'aider


bon dev
<!-- e --><a href="mailtoConfusediehabib@yahoo.fr">siehabib@yahoo.fr</a><!-- e -->
Re..

Avec WDMap - Visionneuse de données, elles sont bien toutes présentent ?

Voir aussi les colonnes de la table si elles sont toutes liées, comme c'est une table fichier.

faloudja

Bonsoir
Mr Samifred

toute les enregistrements sont present et la photo aussi

dans ma table non
et mon fichier quand je clic sur mondifier , tous les champs sont la : sauf la photo

merci de m'aider

bon dev
<!-- e --><a href="mailtoConfusediehabib@yahoo.fr">siehabib@yahoo.fr</a><!-- e -->
Re..

C'est toute une/des colonnes qui sont vident ou quelques lignes aléatoirement ?

...

faloudja

Bonsoir
je l'ai voir maintenant dans la table

sauf la photo dans ma fenetre principal depart

et dans la fenetre fichier


merci de m'aider

<!-- e --><a href="mailtoConfusediehabib@yahoo.fr">siehabib@yahoo.fr</a><!-- e -->

corrdialement
bon dev
Re..

Il faut voir si la photo est liée au fichier... pour les deux situation !

...

faloudja

Bonsoir

c'est bien lie
puise je la voir dans WMap

code du bnt selection

sSel est une chaîne
sSel = fSélecteurImage("", "Fichier.jpg", "Sélectionner une image","JPEG (*.JPG)"+ TAB +"*.jpg"+ RC +"BMP (*.BMP)"+ TAB +"*.bmp"+ RC +"PNG (*.PNG)"+ TAB +"*.png"+ RC +"GIF (*.GIF)"+ TAB +"*.gif")
SI sSel<>"" ALORS
fCopieFichier(sSel,fRepEnCours()+"\Photos\"+ExtraitChaîne(sSel,1,"\",DepuisFin),frConfirmer)
CheminPhoto = fRepEnCours()+"\Photos\"+ExtraitChaîne(sSel,1,"\",DepuisFin)
Photo = CheminPhoto
FIN



merci de m'aider

<!-- e --><a href="mailtoConfusediehabib@yahoo.fr">siehabib@yahoo.fr</a><!-- e -->
bon dev
Re..

Dans le code de la table, sélection d'une ligne... il doit y avoir...

FichierVersEcran()


C'est correcte ?
Pages : 1 2