Forums développeurs windev

Version complète : [RÉSOLU]connexion Internet via une adresse http:\\
Vous consultez actuellement la version basse qualité d’un document. Voir la version complète avec le bon formatage.
Bonjour, j'aimerais savoir , si cela est possible avec la version de Windev 10, d'effectuer une connexion internet pour une recherche
d'image et de résumé de film ?
je m'explique
je m'amuse à créer un programme qui gère une collection de dvd !
en sélectionnant un titre, j'aimerais établir une connexion internet, qui me permettrais de trouver l'affiche de ce film, ou une image
de ce film, ainsi qu'un résumé !
je sais que l'on peut trouver cela sur google entre autre, mais j'aimerais le faire à partir de mon programme !
en fait, récupérer le titre sélectionné dans la table te faire une recherche sur le net !
je pense que cela doit être possible, mais je ne sais pas comment faire !
merci de votre aide à tous

voici le code trouvé dans l'aide de windev !
mais cela ne me donne rien ! lol doit y avoir autre chose à faire, mais je ne sais pas !


ResConnexion,ResLancement est un booléen
ResConnexion = InternetConnecté()

ResLancement = HTTPRequête("http://www.allocine.fr/")

// Si erreur rencontrée
SI ResLancement = Faux ALORS
// Selon le type d'erreur rencontré
SELON ErreurInfo(errCode)
// Certificat invalide ou ne provenant pas d'une société connue
CAS HTTPErreurCertificatInvalide :
// Ignorer le certificat ?
SI OuiNon("Attention, une alerte de sécurité a été détecté !", ...
"Le certificat est invalide.", ...
"Voulez-vous ignorer ce certificat ?") = Oui ALORS
HTTP.IgnoreErreur = HTTPIgnoreCertificatInvalide
// Nouveau lancement de la requête en ignorant cette erreur
HTTPRequête("http://www.allocine.fr/")
FIN
// Date du certificat non-valide ou expiré
CAS HTTPErreurCertificatExpiré :
// Ignorer la date du certificat ?
SI OuiNon("Attention, une alerte de sécurité a été détecté !", ...
"La date du certificat est invalide ou expiré.", ...
"Voulez-vous ignorer cette date ?") = Oui ALORS
HTTP.IgnoreErreur = HTTPIgnoreCertificatExpiré
// Nouveau lancement de la requête en ignorant cette erreur
HTTPRequête("http://www.allocine.fr/")
FIN
FIN
FIN
Bonjour,

Regardez du côté des API AlloCiné ou IMDB.
merci, je vais aller voir de ce côté là !
mais comment procéder au niveau de windev ?
je suis assez novice en programmation