Forums développeurs windev

Version complète : [RÉSOLU]Lister le contenu d'un CD ?
Vous consultez actuellement la version basse qualité d’un document. Voir la version complète avec le bon formatage.
Bonjour à tous, je suis sous windev 10 et je voudrais savoir comment lister le contenu d'un CD en enregistrant ce contenu dans une table !
en fait, ce Cd contient environ 6 films, que je voudrais lister et enregistrer dans une table
je me sers bien de la fonction listefichier, mais si le Cd contient 6 films, cela me copie 6 fois le ,même film ! lol
merci à tous
voici le code d'ouverture du sélecteur qui me permet de sélectionner tous les films présent sur le Cd !
mais cela ne m'en copie qu'un seul !
ensuite le code de la procédure !


SI OuiNon(" Vous allez ajouter des films sans le genre ni le numéro du Cd ... ",...
+ " Vous devrez le faire manuellement !") = Oui ALORS
NbFichierLS est un entier
NbFichierAvi est un entier
CritèreRecherche est une chaîne
ResFichier est une chaîne
NomFilm est une chaîne

NomFilm = fSélecteur("E:\", "", "Sélectionner un fichier",...
"Tous fichiers (*.avi)"+TAB+"*.*", "", fselMulti)

ResFichier = fExtraitChemin(NomFilm, fFichier)
NbFichierAvi = fListeFichier(CritèreRecherche, "AttributFichier", &NbFichierLS)
HLitRecherche(Films,Titre,ResFichier)
SI HTrouve(Films)= Vrai ALORS
Erreur(" Ce Film exisre déjà dans votre Liste et ne peut être ajouté ! " )
TableAffiche(Table,taInit)
RETOUR
FIN
Films.Titre = ResFichier
TableAjouteLigne(Table,Titre)
TableEnregistre(Table)
FIN



PROCEDURE AttributFichier(Repertoire, Nom, Change, NbFichierAvi)
NbFichierLS est un entier
TableAjouteLigne(Table,Nom)
TableEnregistre(Table)
TableAffiche(Table,taCourantPremier)
NbFichierLS++
RENVOYER Vrai


quelqu'un peut il m'aider svp ?
merci
Bonjour,

Pour finir tu as quelle version ????

Tu poses la même question dans le forum version 7.5

Il faut choisir une fois pour toute un forum... :roll: :mrgreen:
désolé, SamiFred, mais à présent que la version 10 fonctionne, j'en reste à la version 10
Merci de ton aide SamiFred
le code que tu m'avais donné fonctionne sous la version 10