Forums développeurs windev

Version complète : Mot de passe pour supprimer un enregistrement
Vous consultez actuellement la version basse qualité d’un document. Voir la version complète avec le bon formatage.
Pages : 1 2

faloudja

Bonjour
je viens chercher de l'aide
j'ai une fenetre avec 3 Btn ajouter / modifer et supprimer
je veux placer un code dans le bounton supprimer qui demande un mot de passe avant de supprimer un enregistrement

Je compte sur vous
Merci de m'aider d'avance

MERCI

faloudja

Bonjour

Je veux insérer un code pour interdire de supprimer l'enregistrement

voici mon code du bouton supprimer

SI TableOccurrence(Table_Etudiant) = 0 OU Table_Etudiant = -1 ALORS RETOUR
SELON OuiNon("Supprimer cette ligne ?")
CAS Oui
TableSupprime(Table_Etudiant,Table_Etudiant)

CAS Non
RETOUR
FIN

faloudja

Bonjour
j'ai besoin de votre aide SVP

Je veux interdire la suppression de l'enregistrement
ou inserer le code.

SI TableOccurrence(Table_Etudiant) = 0 OU Table_Etudiant = -1 ALORS RETOUR
SELON OuiNon("Supprimer cette ligne ?")
CAS Oui
TableSupprime(Table_Etudiant,Table_Etudiant)

CAS Non
RETOUR
FIN


merci de M'aider
bon dev
Depuis 2008 que tu as Windev, tu ne sais toujours pas faire un truc aussi basique ?
si Sai_MDP="toto"
on peut supprimer
sinon
on peu pas
fin
Dans ce cas refait le cours d'autoformation.
Car si quelqu'un te donne la réponse tu n'avanceras jamais.

faloudja

Bonjour
et merci pour ton aide

c'est aussi simple

merci de m'avoir aider


bon dev et bonne fête de PÂQUE

faloudja

wd55 a écrit :Depuis 2008 que tu as Windev, tu ne sais toujours pas faire un truc aussi basique ?
si Sai_MDP="toto"
on peut supprimer
sinon
on peu pas
fin
Dans ce cas refait le cours d'autoformation.
Car si quelqu'un te donne la réponse tu n'avanceras jamais.



Bonjour
s’inscrire et débuter a utiliser windev est très différents

MERCI DE M'AIDER
SI TU LE VEUX
BON DEV
Bonjour,

Il faut premièrement enregistrer un mot de passe crypté dans une fichier externe ou HF ou encore dans le registre afin de pouvoir le comparer au moment de la suppression de données.
Ce mot de passe sera déterminé et enregistré par l'administrateur de l'application ou éventuellement par un utilisateur de confiance.

Ensuite il suffit à chaque suppression de lire le mot de passe enregistré et le comparer au mot de passe saisi. Cette comparaison doit être associée à une condition qui va autoriser ou non la suppression des données.

SI <MotDePasseSaisi> = <MotDePasseEnregistré> ALORS
SELON OuiNon("Confirmez-vous la suppression ?")
CAS Non : RETOUR
CAS Oui : //Traitement de suppression
FIN
SINON
Erreur("Mot de passe incorrect !")
FIN



Voilà en gros le plus simple.
Bon dev.

faloudja

Bonjour
Et merci beaucoup Mr Samifred

je tiens encore une deuxieme fois a te remercier
pour la premiere fois que j'ai demande de l'aide sur mon projet etudiant , tu m a vraiment aider
et j'ai bien compris certains processus de programmation de windev
Pour ne pas trop te demander ; je ne comprends pas comment crypter mon mot de passe et faire mot de passe externe

stp donne un exemple
et aide moi a comprend
MERCI DE M'AIDER

Bonne fete de PAQUE
<!-- e --><a href="mailtoConfusediehabib@yahoo.fr">siehabib@yahoo.fr</a><!-- e -->
Re..

Regardes ton email <!-- e --><a href="mailtoConfusediehabib@yahoo.fr">siehabib@yahoo.fr</a><!-- e --> tu as une petite fenêtre exemple...

Bon dev.

faloudja

Bonjour Samifred

ET MERCI BEAUCOUP POUR TON AIDE

QUE DIEU TE BENISSE


merci de m'avoir aider
Bon dev
Pages : 1 2