Forums développeurs windev

Version complète : Message d'erreur lors de l'envoi du mail
Vous consultez actuellement la version basse qualité d’un document. Voir la version complète avec le bon formatage.
Bonjour à tous
je développe une application qui va permettre d'envoyer des mails aux différents agents de la structure
mais un message d'erreur apparait, et je ne comprends pas

[Image: C:\Users\K YANICK K\Desktop]

voici mon code


MaSession est un EmailSessionSMTP
MaSession..AdresseServeur = "smtp.gmail.com"
MaSession..MotDePasse = "xyanxxx01"
MaSession..Port=587
MaSession..Option = emailOptionSécuriséTLS
MaSession..Nom="yanickxxx@gmail.com"

EmailChangeTimeOut(30) //10 secondes pour le time out

SI EmailOuvreSession(MaSession) = Faux ALORS
    
    
    Message("La connexion a échouée.")
    Erreur("Impossible d'ouvrir la session SMTP.", ErreurInfo(), ...
    "En cas de TimeOut, assurez-vous des paramètres du ""Pare-Feu"" sur le port utilisé ("+...
    MaSession..Port+")")
    
    
    RENVOYER Faux
FIN

Email.Expéditeur = "yanickxxx@gmail.com"

Email.Destinataire = "yanickxxx@gmail.com"


Email.Sujet="Erreur Log "+SAI_Objet

Email.Message= DateVersChaîne(DateSys())+ " " +HeureVersChaîne(HeureSys()) +RC+"ste"+RC+ SAI_Message

Email.NbAttache = 0

Email.NbDestinataire = 1 // Le nombre de destinataires

SI PAS EmailEnvoieMessage(MaSession) ALORS
    Erreur("Erreur envoi : "+ ErreurInfo())
FIN
EmailFermeSession(MaSession)

Merci d'avance
Bonsoir
Le problême semble venir de Gmail.
Sur un autre forum il y a des solutions.
Mais la majorité ne fonctionne que de temps à autre.
Il faudrai travailler sur le problême pour trouver une solution.
La seule qui marche toujours c'est un petit module fait en WD22, que je n'ai pas.
Si quelqu'un l'a et peut collaborer.....
Bonjour,

Je confirme.... Gmail !

Je n'ai pas ce module non plus... attendons une âme charitable.

Bon dev, Daniel.
Bonjour,

Je comprends pas... pourquoi toujours Gmail. Moi je passe par mon fournisseur d'accès internet Bluewin.ch pour ne pas le citer
et n'ai aucun problème. Mes mails sont envoyés/réceptionnés avec ou pas pièce jointe sans erreur.

Ou alors j'ai rien compris... quel module ?

Cordialement, Samifred
Bonjour,

Tu as parfaitement raison SamiFred ; moi je passe par orange et aucun problème.

Mais les choix des uns ne sont pas les choix des autres...

Gmail est effectivement un peu "chi...".
(29-12-2017, 10:05 AM)Samifred a écrit : [ -> ]Bonjour,

Je comprends pas... pourquoi toujours Gmail. Moi je passe par mon fournisseur d'accès internet Bluewin.ch pour ne pas le citer
et n'ai aucun problème. Mes mails sont envoyés/réceptionnés avec ou pas pièce jointe sans erreur.

Ou alors j'ai rien compris... quel module ?

Cordialement, Samifred

Bonjour Samifred
j'ai changé mon serveur SMTP VOICI MON CODE


MaSession est un EmailSessionSMTP
MaSession..AdresseServeur = "smtp.live.com"
MaSession..Port=25
MaSession..Option = emailOptionDéfaut
MaSession..Nom="yanickXXX@hotmail.com"
MaSession..MotDePasse = "XXXXX05"

EmailChangeTimeOut(70) //10 secondes pour le time out

SI EmailOuvreSession(MaSession) = Faux ALORS
    
    Message("La connexion a échouée.")
    Erreur("Impossible d'ouvrir la session SMTP.", ErreurInfo(), ...
    "En cas de TimeOut, assurez-vous des paramètres du ""Pare-Feu"" sur le port utilisé ("+...
    MaSession..Port+")")
    
    RENVOYER Faux
FIN

Email.Expéditeur = "yanickXXX@hotmail.com"

Email.Destinataire = "yanickXXX@yahoo.fr"

Email.Sujet=SAI_Objet

Email.Message= DateVersChaîne(DateSys())+ " " +HeureVersChaîne(HeureSys()) +RC+"ste"+RC+ SAI_Message

Email.NbAttache = 0

Email.NbDestinataire = 1 // Le nombre de destinataires

SI PAS EmailEnvoieMessage(MaSession) ALORS
    Erreur("Erreur envoi : "+ ErreurInfo())
FIN
EmailFermeSession(MaSession)


[attachment=68]
kamdem
(29-12-2017, 10:05 AM)Samifred a écrit : [ -> ]Bonjour,

Je comprends pas... pourquoi toujours Gmail. Moi je passe par mon fournisseur d'accès internet Bluewin.ch pour ne pas le citer
et n'ai aucun problème. Mes mails sont envoyés/réceptionnés avec ou pas pièce jointe sans erreur.

Ou alors j'ai rien compris... quel module ?

Cordialement, Samifred
   
  

Bonjour a tous j'ai pu résoudre mon problème

en effet il fallait juste aller dans les options de sécurité de mon email pour autoriser l'envoi via une application externe
Comme le montre l'image ci dessous
Merci a tous pour vos contributions
Merci du suivi !

Bon dev, Daniel