Forums développeurs windev

Version complète : Affichage données fichier dans table mémoire
Vous consultez actuellement la version basse qualité d’un document. Voir la version complète avec le bon formatage.
Bonjour,

J'ai besoin de votre aide car je "patauge" vraiment sur mon application...
J'ai créé une table mémoire ou je voudrais afficher 1 ligne de mon fichier à la sélection de ma combo.

Ma combo est remplie par programmation et elle affiche différents produits, quand je sélectionne un produit dans ma combo je voudrais que la valeur s'affiche dans ma table mémoire, et cela pour différentes années.

Ma combo = combo_produits
Ma table mémoire = Table_1

J'ai 4 colonnes dans ma table mémoire, avec : Valeur année 2009, Valeur année 2010, Valeur année 2011, Valeur année 2012

Besoin d'aide please :roll:
Bonjour,

Tu as quelle version de Windev... la 10 ou supérieur... ? ou alors tu te trompes de forum...

Pour la combo il faut voir si tu sélectionnes la valeur affichée ou mémorisée (gLien())

Pour la table il faut voir du côté de Tableau croisé dans l'aide et tu crées un état croisé avec l'assistant c'est tout simple.

Bon courage. Windev c'est facile... mais avec le temps.. :mrgreen:
Bonjour, j'ai réussi de cette façon là :

Code :
TableSupprimeTout(TABLE_1)
nNNiveau=COMBO_Niveau..ValeurMémorisée


sReqLib="SELECT * FROM PD WHERE IDParamPDM="+nNNiveau

sReqLib+=" ORDER BY DATE, IDCR"

SI PAS HExécuteRequêteSQL(sdReqLib,sReqLib) ALORS
    Erreur(HErreurInfo())
FIN

POUR TOUT sdReqLib
    
    bTrouve=Faux
    nNocc=TABLE_1..Occurrence
    POUR i = 1 A nNocc
        SI sdReqLib.IDCR=TABLE_1.COL_CA[i] ALORS
            bTrouve=Vrai    
            SORTIR
        FIN
        
    FIN
        SI bTrouve= Faux ALORS         
            TableAjoute(TABLE_1)
            TableSelectPlus(TABLE_1,TableOccurrence(TABLE_1))
            TABLE_1.COL_CA=sdReqLib.IDCR
            i=TableOccurrence(TABLE_1)
        FIN
    
    
    SELON sdReqLib.Date..Année
        CAS 2009 :
            TABLE_1.COL_2009[i]=sdReqLib.Mnt_CR
            
            
        CAS 2010 :
            TABLE_1.COL_2010[i]=sdReqLib.Mnt_CR
            
        CAS 2011 :
            TABLE_1.COL_2011[i]=sdReqLib.Mnt_CR

        CAS 2012 :
            TABLE_1.COL_2012[i]=sdReqLib.Mnt_CR

        CAS 2013 :
            TABLE_1.COL_2013[i]=sdReqLib.Mnt_CR

            
        AUTRE CAS : Info("Année non existante")
            
    FIN
    
FIN

HLibèreRequête(sReqLib)