Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
probleme avec combo
#11
Bonsoir,

Je verrais comme ceci... mais je comprend pas bien la condition après le TANTQUE, doit-on sortir de la boucle ??? j'ai ajouter un SORTIR en commentaire.

Code :
gbEtat est un booléen = Faux

HLitPremier(services, RubriqueClé)  //Sur une rubrique clé

TANTQUE PAS HEnDehors(services)
    SI services.responsable = SAI_login ET services.mdp = SAI_mdp ALORS
        gbEtat = Vrai
      //SORTIR
    FIN
    HLitSuivant(services, RubriqueClé)
FIN

SI gbEtat = Faux  ALORS
    PageAffiche(PAGE_creationemploye)
SINON   //ce code sinon est en anomalie rouge je ne comprends pas pourquoi (par ce que il n'y avait pas de FIN !)
    PageAffiche(PAGE_fiche personnel)
FIN

...

En espérant que j'ai compris....
Se souvenir et savoir sont deux choses différentes. Se souvenir, c'est garder en mémoire. En revanche, savoir signifie assimiler sans dépendre d'un modèle.

WD 4.1 => 23




Sujets apparemment similaires…
Sujet Auteur Réponses Affichages Dernier message
  probleme avec menu d'une page kameram 1 2,284 10-08-2012, 10:04 AM
Dernier message: beginner

Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)