Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
combobox vide
#1
Salut le forum,

J ai un souci avec une combo box alimenté par une requête provenant d'une base access.
dans la phase de programmation la combo box affiche bien les données mais une fois compilé
elle reste vide alors que la requête s’exécute correctement.
j'ai voulu faire la même chose avec une table et j'ai le même problème,
auriez vous une solution SVP merci
XLGUY
Répondre
#2
(21-12-2019, 05:02 PM)XLGUY a écrit : Salut le forum,

J ai un souci avec une combo box alimenté par une requête provenant d'une base access.
dans la phase de programmation la combo box affiche bien les données mais une fois compilé
elle reste vide alors que la requête s’exécute correctement.
j'ai voulu faire la même chose avec une table et j'ai le même problème,
auriez vous une solution SVP merci
XLGUY
Bonjour XLGUY,
En cette veille de fêtes soit indulgent pour nos neurones.
Voudrais tu nous poster tes  quelques lignes de code permettant de remplir ta combo même si tu es certain qu'elles sont bonnes.
A bientôt .
Programmeur non confirmé en WinDev 9
Non professionnel
Répondre
#3
Salut Emile
il n'y a pas de code pour alimenter la combo, est est reliée a la requête directement dans la description
et même avec une combo par programmation elle reste vide en déploiement (sauf sur le PC qui sert a programmer)
Merci
A+
Répondre
#4
(23-12-2019, 09:31 AM)XLGUY a écrit : Salut Emile
il n'y a pas de code pour alimenter la combo, est est reliée a la requête directement dans la description
et même avec une combo par programmation elle reste vide en déploiement (sauf sur le PC qui sert a programmer)
Merci
A+

Je me répond a moi même...
j'ai supprimé la requête qui avait des tris et des filtres et fait une combo par programmation directement
avec le fichier de données et par miracle sa marche.
un bug de windev sans doute
joyeux noël a tous
Répondre


Sujets apparemment similaires…
Sujet Auteur Réponses Affichages Dernier message
  [Windev 20] Impression vide Alext11 2 2,403 06-10-2016, 03:40 PM
Dernier message: Alext11
  Ligne d'une table vide miloudsat 9 4,451 28-04-2016, 12:34 PM
Dernier message: TheDuke
  affichage champ image vide Francois 6 3,983 18-01-2016, 08:23 PM
Dernier message: Francois
  Champs de saisie de type numérique ou date vide aprés affectation indefin 7 5,480 14-12-2015, 06:42 AM
Dernier message: gaymath2
  Repertoire Zip vide augure2004 1 1,369 23-07-2015, 11:29 AM
Dernier message: tunidev_mybb_import2
  {WD19] Problème de modification de la base HFSQL/Combobox Askior94 0 1,236 31-07-2014, 08:05 AM
Dernier message: Askior94
  [WD12] Problème sur champs vide sur un HAjoute Guest 4 3,402 26-02-2014, 08:39 AM
Dernier message: Guest
  libelle est vide sstolga 1 1,260 30-12-2012, 11:08 AM
Dernier message: Madsl@nd
  Etat des champs selctionné d'une table est Vide Ramsi 7 2,269 24-12-2012, 01:07 PM
Dernier message: Ramsi
  [RESOLU] Se positionner sur première ligne vide d'une table Icho 8 3,128 08-10-2012, 06:49 AM
Dernier message: Icho

Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)