Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
ce connecter à une base Access
#1
Code :
//Variables de connexion
sNomConnexion est une chaîne = "CNX_ACCESS"
sTypeConnexion est une chaîne = "Microsoft.Jet.OLEDB.4.0"
sTypeAccès est un entier = hOLectureEcriture
sNomSource est une chaîne = "C:\MaBaseAccess.mdb"
sNomBase est une Source de Données = ""
sNomUtilisateur est une chaîne = ""
sMotDePasse est une chaîne = ""
sInfoEtendus est une chaîne = ""

SI HDécritConnexion(sNomConnexion, sNomUtilisateur, sMotDePasse, sNomSource, sNomBase, sTypeConnexion, sTypeAccès) ALORS
SI HOuvreConnexion(sNomConnexion) ALORS

HChangeConnexion(Cedex,"CNX_ACCESS")
Info("Connexion créée. Changement de connexion effectué")
SINON
Erreur(HErreurInfo())
FIN
SINON
Erreur(HErreurInfo())
FIN
Répondre


Sujets apparemment similaires…
Sujet Auteur Réponses Affichages Dernier message
  Lister les tables d'une base ACCESS ASG2012 0 2,131 30-06-2011, 11:57 AM
Dernier message: ASG2012

Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)