Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
Tablecherche
#1
Bonjour à tous,
Profitant de cette malheureuse période de confinement, j'essaye de mettre à jour mes habitudes de développement que j'ai délaissé depuis quelques temps pour causes de manque de temps, je me trouve bloquer avec un code que je n'arrive pas à trouver la réponse escomptée. J'ai voulu fusionner les colonnes d'une table en fonction du mois affiché dans chaque ligne. Le résultat du code donne une fusion total de la colonne "mois" bien qu'il existe plusieurs mois différents.
Merci pour votre aide.

TableSupprimeTout(Table1)
j,cp,res    sont des entiers
tot est une chaîne
ch   est une chaîne
dDhjour est une Date=PremierJourDeLaSemaine(SAI_Date)
masemaine est une Date = dDhjour
monmois est une Date = (SAI_Date)
rescherche est un entier
x est un entier
Sais_Fic = ""
POUR i=1 À SAI_Entier1
    dDhjour..Jour+=7
    TableAjouteLigne(Table1,dDhjour..Mois,NuméroDeMoisVersLettre(dDhjour..Mois),NuméroDeSemaine(dDhjour),dDhjour)
    FIN
j    =1
cp    = TableOccurrence(Table1)
TANTQUE j <= cp
    ch = Table1.Colonne2[j]
    POUR TOUTE LIGNE DE Table1
        
    
        SI Table1.Colonne2 = ch ALORS
            
        FIN
    FIN
    POUR TOUTE LIGNE DE Table1
        res = TableCherche(Colonne1,ch,Vrai,1)
        SI res = -1 ALORS
            Colonne2[j]..Fusion = fusionLigneSuivante
                Trace(ch,j,Colonne1)        
        FIN   
    FIN
    tot = ""
    j++
FIN
Répondre


Sujets apparemment similaires…
Sujet Auteur Réponses Affichages Dernier message
  tablecherche dans deux tables sur deux colonnes XLGUY 3 2,927 28-07-2014, 07:02 PM
Dernier message: Samifred
  tablecherche et fichier texte moradsoft 9 2,346 15-12-2013, 04:06 PM
Dernier message: Samifred
  Tablecherche ABDOU 7 2,381 19-02-2012, 12:22 PM
Dernier message: ABDOU
  tablecherche si fenetre contient deux tables gwing 2 1,136 04-10-2011, 10:04 AM
Dernier message: gwing

Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)