Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
Supprimer un fichier texte
#1
voila ce que j'ai ecris

pour tout ligne selectionné de table
fSupprime("C:\Mes Projets\F_STAT\"+table.Nom_fichier_txt+".txt")
fin

le fichier n'est pas supprimé
comment faire?
Répondre
#2
voila le message d'erreur

"Impossible de supprimer le fichier <monfichier>. Détail de l'erreur système : Le processus ne peut pas accéder au fichier car ce fichier est utilisé par un autre processus."
J'ai fait plusieurs tests de fermeture mais rien n'y fait.
Le seul moyen que j'ai trouvé est de fermer l'application pour libérer le fichier.
Une idée ?
Répondre
#3
C'est quoi comme fichier.. HF ou externe ?
Se souvenir et savoir sont deux choses différentes. Se souvenir, c'est garder en mémoire. En revanche, savoir signifie assimiler sans dépendre d'un modèle.

WD 4.1 => 23


Répondre
#4
c'est un fichier externe (fichier texte contient un code sql)
Répondre
#5
salam

utilse le code resultouvre=fouvre(fichiertext) et a la fin de traitement il faux fermer le fichier avec
fFerme(resultouvre)


alors tu peu pas supprimer un fichier deja ouver alors fermer avant





salam
[b]Jihad
[url]http://www.jhd-soft.com[/url][/b]
Répondre
#6
Une solution...

pour tout ligne selectionné de table
fFerme("C:\Mes Projets\F_STAT\"+table.Nom_fichier_txt+".txt")
fSupprime("C:\Mes Projets\F_STAT\"+table.Nom_fichier_txt+".txt")
fin
Se souvenir et savoir sont deux choses différentes. Se souvenir, c'est garder en mémoire. En revanche, savoir signifie assimiler sans dépendre d'un modèle.

WD 4.1 => 23


Répondre
#7
re salam

salut Samifred je crois
en ferme "l'identifiant du fichier" ne pas le fichier
exemple
IdFichier = fOuvre("C:\MesRépertoires\Fichier.txt", foLectureEcriture)
SI IdFichier <> -1 ALORS
...
// Fermeture du fichier externe
ResFerme = fFerme(IdFichier)
FIN



salam
[b]Jihad
[url]http://www.jhd-soft.com[/url][/b]
Répondre
#8
Ton fichier ne peut se supprimer que si tu le ferme au préalable

Tu doit ajouter la ligne suivante avant fSupprime)

fFerme(le chemin du fichier)

Faute de quoi, windev considère que tant que la fichier est ouvert, il ne peut le supprimer

Raptor92
Répondre
#9
merci pour vos repenses ,j'ai essayé mais le meme probleme existe voila mon code:

POUR TOUTE LIGNE SELECTIONNEE DE TABLE_FEN_Ajouter_Requette
ResSuppression est un booléen
sFichieraSupprimer est une chaîne
sFichieraSupprimer=TABLE_FEN_Ajouter_Requette.COL_Localisation

////suppression du fichier text
fFerme(TABLE_FEN_Ajouter_Requette.COL_Localisation)
ResSuppression=fSupprime(sFichieraSupprimer)
SI ResSuppression = Faux ALORS
Erreur(ErreurInfo( errMessage ))
SINON
Info("Le fichier a été supprimé")
FIN
////suppression dans la base
HLitRecherche(REQ,IDRequete,REQ.IDRequete,hIdentique)
SI HTrouve(REQ)=Vrai ALORS
HSupprime(REQ,hNumEnrEnCours)
TableSupprime(TABLE_FEN_Ajouter_Requette)
SINON
Info("Une erreur a été détectée pendant la récupération des données.")
FIN

FIN
Répondre
#10
salam


je crois que je bien dit qu on ferme lidentifiant du fichier ne pas le nom de fichier !!!!


il faux que tu connaitre Identifiant du fichier du fichier pour le fermer

pour le connaitre il faux metre l'overture du fichier txt dans un variabl Numirique exemple

IdentifiantFichier = fOuvre("nomfichier")
et la fin en ferme le fichier avec
fferme(IdentifiantFichier ) est c pas comme fFerme(TABLE_FEN_Ajouter_Requette.COL_Localisation)




salam

....
[b]Jihad
[url]http://www.jhd-soft.com[/url][/b]
Répondre


Sujets apparemment similaires…
Sujet Auteur Réponses Affichages Dernier message
  [RESOLU] Fichier texte et GREP Talmebadia 0 761 08-02-2019, 04:10 PM
Dernier message: Talmebadia
  Création fichier texte bruno rodrigues 13 5,457 07-06-2017, 03:21 PM
Dernier message: bruno rodrigues
  ajouter, Modifie et supprimer miloudsat 1 2,451 18-02-2015, 02:58 PM
Dernier message: Daniel-Québec
  Exporter fichier texte[Windev 19] ktimite 6 3,244 21-01-2015, 05:30 PM
Dernier message: helmi
  Supprimer PDF en cours de visualisation dans table image Arner 6 2,104 02-04-2014, 10:17 AM
Dernier message: Arner
  lecture fichier texte sans séparateur moradsoft 3 2,151 04-01-2014, 07:09 PM
Dernier message: jibi049
  tablecherche et fichier texte moradsoft 9 2,329 15-12-2013, 04:06 PM
Dernier message: Samifred
  lecture fichier texte aprés detection de caractére moradsoft 1 1,596 08-12-2013, 08:59 AM
Dernier message: Samifred
  Fichier variable dans texte ouizette 2 1,241 01-10-2013, 02:26 PM
Dernier message: ouizette
  Importation d'un fichier texte dans une table mémoire ou fic mitnick 6 3,087 08-08-2013, 06:54 PM
Dernier message: Samifred

Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)