Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
Service Windev ne fonctionne qu'en Debug
#1
Bonjour,

J'utilise Windev 17 version 01F170078n.
J'ai créé un projet ServiceI, me permettant de surveiller les fichiers d'un répertoire, si le nom d'un fichier a été trouvé, dans ce cas un executable est lancé en ligne de commande.
Mon problème est que cela fonctionne très bien en "Déboguer en tant que service", mais après avoir fait l'installation de ce service, cela ne fonctionne pas du tout.
J'ai vérifié que mon service soit bien présent et démarré dans les services Windows, c'est bien le cas, dans l'observateur d'évènement de windows je n'ai pas d'erreur sur ce service.
Dans le code d'exécution du service (appelé en boucle), j'y ai ajouté l'écriture dans un fichier log me permettant de savoir si le traitement était bien exécuter, ce n'est pas le cas, j'ai l'impression qu'il ne passe pas du tout dans cette partie, par contre il passe bien dans la partie "Initialisation de serviceI".

J'ai vérifié dans l'aide et je ne trouve pas les réponses à mes questions, de plus, j'ai regardé les différents exemples didactiques concernant les services et j'en suis toujours au même point.

Auriez vous une idée ?
Merci par avance.
Répondre


Sujets apparemment similaires…
Sujet Auteur Réponses Affichages Dernier message
  web service lst 99 Alain18 0 904 08-05-2018, 08:34 AM
Dernier message: Alain18
Sad Hfiltre ne fonctionne pas !!! Bizarre non? mohamedhdih 4 2,138 19-01-2017, 03:51 PM
Dernier message: mohamedhdih
  Application service mk1708 3 2,362 25-08-2015, 09:32 PM
Dernier message: jibi049
  [WD17]Pb de fenêtre dans un service Saru 4 1,380 18-01-2013, 09:54 AM
Dernier message: Saru
  comment acceder par internet à un service web melekhb 9 4,967 18-06-2012, 05:46 PM
Dernier message: Madsl@nd
  [w16] mise en place d'un service oxford 10 2,906 19-07-2011, 08:38 AM
Dernier message: Saru
  [WD12] Service Windows qui interagit avec Excel herve63 0 988 06-07-2011, 08:40 AM
Dernier message: herve63
  Liens de l'aide ne fonctionne plus 974JmG 2 1,174 17-06-2011, 04:34 AM
Dernier message: 974JmG
  Acces BD via ODBC ne fonctionne pas en WebService plt 0 1,297 31-03-2011, 01:56 PM
Dernier message: plt
  CREATION D'UNE APPLICATION SERVICE molo100 2 1,151 04-03-2011, 05:19 PM
Dernier message: panamdz

Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)