Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
Récupérer résultats requête SQL par un webservice
#1
Bonsoir
J'ai une table MySQL aja_rep_profil, et qui contient les champs suivant, id, nom, prénom, adresse, tél, j'ai développé un web-service pour récupéré les enregistrements stocké dans cette table avec le code suivant :
PROCEDURE gPR_Get_Profil()
NumConnexion est un entier
sChaineSQL est une chaîne
bRes est un booléen
tabResultat est un tableau de chaîne
NumConnexion = gPR_OuvrirBase()

SI NumConnexion = 0 ALORS
// La connexion a échoué : affichage d'un message explicatif
// SQLInfoGene()
RENVOYER Faux
//RETOUR
FIN
sChaineSQL = "SELECT * FROM rep_tb_profil"
bRes = SQLExec(sChaineSQL, "REQ_GET_PROFIL")
SI bRes = Faux ALORS
//Si l'execution de la requete ne se passe pas bien
RENVOYER Faux
FIN
TANTQUE SQLAvance("REQ_GET_PROFIL") = 0
TableauAjoute(tabResultat, SQLLitCol("REQ_GET_PROFIL",1))
TableauAjoute(tabResultat, SQLLitCol("REQ_GET_PROFIL",2))
TableauAjoute(tabResultat, SQLLitCol("REQ_GET_PROFIL",3))
TableauAjoute(tabResultat, SQLLitCol("REQ_GET_PROFIL",4))
FIN

SQLFerme("REQ_GET_PROFIL")
SQLDéconnecte()
RENVOYER tabResultat

cette procédure ne tourne rien Aide moi s'il vous plait.
Bonne soirée.
#2
perso je testerai si la boucle se fait bien un trace(SQLLitCol("REQ_GET_PROFIL",1))
TANTQUE SQLAvance("REQ_GET_PROFIL") = 0
trace(SQLLitCol("REQ_GET_PROFIL",1))
TableauAjoute(tabResultat, SQLLitCol("REQ_GET_PROFIL",1))
TableauAjoute(tabResultat, SQLLitCol("REQ_GET_PROFIL",2))
TableauAjoute(tabResultat, SQLLitCol("REQ_GET_PROFIL",3))
TableauAjoute(tabResultat, SQLLitCol("REQ_GET_PROFIL",4))
FIN



si le race n'affiche rien le pb est dans la requête,
si un résultat s'affiche alors c'est le passage de variable vers la chaine attendue du tableau (pourquoi ???)
je testerai alors en passant par un variable chaine


sVT est une chaine
TANTQUE SQLAvance("REQ_GET_PROFIL") = 0
sVT =SQLLitCol("REQ_GET_PROFIL",1)
TableauAjoute(tabResultat, sVT)
TableauAjoute(tabResultat, SQLLitCol("REQ_GET_PROFIL",2))
TableauAjoute(tabResultat, SQLLitCol("REQ_GET_PROFIL",3))
TableauAjoute(tabResultat, SQLLitCol("REQ_GET_PROFIL",4))
FIN




sinon as tu essayé avec TaleauAjouteLigne


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)