Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
[RÉSOLU] exporte une table en fichier texte ?
#1
Bonjour à tous,
je m'arrache les cheveux ........
j'ai une table contenant environ 500 titres de films !
un bouton pour copier le liste de ces films dans un fichier texte !
jusque là, tout va bien ! la liste de ces 500 films est crée
dans une autre table, contenant la liste des genres de ces films, j'ai le même bouton avec le même code !
environ 50 genres !
la table ne m'affiche que 19 lignes, et le code ne me copie que ces 19 lignes !
pourquoi cela fonctionne dans une liste de 500 fims, et pas dans une liste de 50 genres ?
merci de votre aide
Répondre
#2
Bonjour,

Toujours publier le code utilisé !

Quel code utilises-tu ? :lol:
Se souvenir et savoir sont deux choses différentes. Se souvenir, c'est garder en mémoire. En revanche, savoir signifie assimiler sans dépendre d'un modèle.

WD 4.1 => 23


Répondre
#3
oups ! désolé !

SI Table..Vide = Vrai ALORS
Erreur(" Votre Table est Vide ! Exportation Impossible !")
SINON
fCrée("Liste des Genres Dvd.txt")
v_nomFichier est une chaîne
numFic est un entier
v_indice est un entier

v_nomFichier =fSélecteur("", "", "Sélectionnez un fichier...", "Liste des Genres Dvd (*.txt)"+TAB+"*Liste des Genres Dvd.txt", "txt", fselCrée)
SI v_nomFichier <> "" ALORS
numFic= fOuvre(v_nomFichier,foCréation)
SI numFic <> -1 ALORS
// sauvegarde des table
POUR v_indice = 1 A TableOccurrence(Table)
fEcritLigne(numFic,Table.Genre[v_indice])
FIN
FIN
FIN
FIN

le même code fonctionne avec la liste des 500 films
Répondre
#4
Essayes comme ceci... (moi je commence toujours par la fin mais à partir du fichier)

Code :
SI Table..Vide = Vrai ALORS
Erreur(" Votre Table est Vide ! Exportation Impossible !")
SINON
fCrée("Liste des Genres Dvd.txt")
v_nomFichier est une chaîne
numFic est un entier
v_indice est un entier

v_nomFichier =fSélecteur("", "", "Sélectionnez un fichier...", "Liste des Genres Dvd (*.txt)"+TAB+"*Liste des Genres Dvd.txt", "txt", fselCrée)
SI v_nomFichier <> "" ALORS
numFic= fOuvre(v_nomFichier,foCréation)
SI numFic <> -1 ALORS
// sauvegarde des table
POUR v_indice = TableOccurrence(Table) _A_ 1 PAS -1
fEcritLigne(numFic,Table.Genre[v_indice])
FIN
FIN
FIN
FIN
Se souvenir et savoir sont deux choses différentes. Se souvenir, c'est garder en mémoire. En revanche, savoir signifie assimiler sans dépendre d'un modèle.

WD 4.1 => 23


Répondre
#5
Merci Monsieur SamiFred,
mais j'ai toujours le même résultat ! 19 lignes !
Répondre
#6
C'est bizarre...

Essayes de lire directement le fichier et c'est plus rapide...

HLitDernier()
TANTQUE PAS HEndehors()
fEcritLigne(....
HLitPrécédent()
FIN
Se souvenir et savoir sont deux choses différentes. Se souvenir, c'est garder en mémoire. En revanche, savoir signifie assimiler sans dépendre d'un modèle.

WD 4.1 => 23


Répondre
#7
merci SamiFred, c'est ce que je viens de faire et ça marche comme ça !
j'aurais du y penser avant de poster cette question !
bonne journée à toi
Répondre


Sujets apparemment similaires…
Sujet Auteur Réponses Affichages Dernier message
  [RÉSOLU]Ouvertute et Lecture d'un fichier externe ? Clovis47 1 2,259 26-06-2013, 01:29 PM
Dernier message: gaymath2
  [RÉSOLU]Incrémentation d'un numéro dans une table ? Clovis47 2 2,073 23-04-2013, 08:51 AM
Dernier message: Clovis47
  [RÉSOLU]Table et Combo triées ? Clovis47 11 3,356 27-10-2012, 03:43 PM
Dernier message: Clovis47
  [RÉSOLU] ligne de table suivant la date du jour ? Clovis47 2 1,529 25-10-2012, 08:44 AM
Dernier message: Clovis47
  [RÉSOLU]Exportation de table vers texte Clovis47 8 2,895 11-10-2012, 04:46 AM
Dernier message: Clovis47
  EXPORTER DES DONNEES D'UNE TABLE VERS UN FICHIER TEXTE.TXT mondray 4 3,546 30-06-2010, 05:40 PM
Dernier message: mondray
  transfert d'une table mémoire vers une table fichier[RESOLU] abdoulay 13 5,172 11-08-2009, 10:55 AM
Dernier message: abdoulay
  Export vers fichier Texte bhdih 5 2,756 02-01-2009, 06:17 PM
Dernier message: bhdih
  Résolu :Couleur ligne d'une table abdoulay 3 6,136 02-12-2008, 12:59 PM
Dernier message: abdoulay
  Créeer fichier texte pour exporter vers Ciel-compta. keith2001 3 6,068 24-04-2008, 07:47 PM
Dernier message: keith2001

Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)