Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
[RÉSOLU]connexion Internet via une adresse http:\\
#1
Bonjour, j'aimerais savoir , si cela est possible avec la version de Windev 10, d'effectuer une connexion internet pour une recherche
d'image et de résumé de film ?
je m'explique
je m'amuse à créer un programme qui gère une collection de dvd !
en sélectionnant un titre, j'aimerais établir une connexion internet, qui me permettrais de trouver l'affiche de ce film, ou une image
de ce film, ainsi qu'un résumé !
je sais que l'on peut trouver cela sur google entre autre, mais j'aimerais le faire à partir de mon programme !
en fait, récupérer le titre sélectionné dans la table te faire une recherche sur le net !
je pense que cela doit être possible, mais je ne sais pas comment faire !
merci de votre aide à tous

voici le code trouvé dans l'aide de windev !
mais cela ne me donne rien ! lol doit y avoir autre chose à faire, mais je ne sais pas !


ResConnexion,ResLancement est un booléen
ResConnexion = InternetConnecté()

ResLancement = HTTPRequête("http://www.allocine.fr/")

// Si erreur rencontrée
SI ResLancement = Faux ALORS
// Selon le type d'erreur rencontré
SELON ErreurInfo(errCode)
// Certificat invalide ou ne provenant pas d'une société connue
CAS HTTPErreurCertificatInvalide :
// Ignorer le certificat ?
SI OuiNon("Attention, une alerte de sécurité a été détecté !", ...
"Le certificat est invalide.", ...
"Voulez-vous ignorer ce certificat ?") = Oui ALORS
HTTP.IgnoreErreur = HTTPIgnoreCertificatInvalide
// Nouveau lancement de la requête en ignorant cette erreur
HTTPRequête("http://www.allocine.fr/")
FIN
// Date du certificat non-valide ou expiré
CAS HTTPErreurCertificatExpiré :
// Ignorer la date du certificat ?
SI OuiNon("Attention, une alerte de sécurité a été détecté !", ...
"La date du certificat est invalide ou expiré.", ...
"Voulez-vous ignorer cette date ?") = Oui ALORS
HTTP.IgnoreErreur = HTTPIgnoreCertificatExpiré
// Nouveau lancement de la requête en ignorant cette erreur
HTTPRequête("http://www.allocine.fr/")
FIN
FIN
FIN
Répondre
#2
Bonjour,

Regardez du côté des API AlloCiné ou IMDB.
Cordialement

Madsl@nD
Répondre
#3
merci, je vais aller voir de ce côté là !
mais comment procéder au niveau de windev ?
je suis assez novice en programmation
Répondre


Sujets apparemment similaires…
Sujet Auteur Réponses Affichages Dernier message
  requette http kamdem 0 961 23-09-2010, 11:18 AM
Dernier message: kamdem
  PROBLEM EXTRAIRE UNE PARTIE DES DONNEES D'UNE PAGE INTERNET tegsons7 0 1,771 12-03-2010, 11:13 PM
Dernier message: tegsons7
  Adresse SMTP Jean-Denis 1 1,196 14-09-2009, 12:10 PM
Dernier message: tunidev_mybb_import2
  installation C/S avec adresse IP et convertir les chiffres e kamdem 2 1,452 16-07-2009, 10:31 AM
Dernier message: CISSOKHO
  Tester connexion internet en WDM 10 xdoomer 0 1,379 28-05-2009, 06:11 PM
Dernier message: xdoomer
  Tester sa coonection internet lepirate 2 1,355 08-11-2008, 09:49 AM
Dernier message: lepirate
  controleur accés internet hamdi amine 0 3,365 25-04-2008, 05:17 PM
Dernier message: hamdi amine
  [RESOLU] Adresse d'une cellule d'un champ table... jo_la_pasteque 3 3,025 08-04-2008, 02:36 PM
Dernier message: jo_la_pasteque
  navigateur WEB et barre d'adresse bbattia 0 2,222 24-03-2008, 09:31 AM
Dernier message: bbattia
  validation d'une adresse email ouni maher 2 2,124 11-02-2008, 08:10 PM
Dernier message: tunidev_mybb_import2

Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)