Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
[RÉSOLU]Ouvertute et Lecture d'un fichier externe ?
#1
Bonjour à tous, je suis sous la version 10 et un peu novice .....
je voudrais ouvrir un fichier externe, lire le contenu et remplir ma table avec ce contenu ! chaque fois, message d'erreur d'ouverture du fichier !
voici le code que j'utilise :


MessageDvd est une chaîne

HLitPremier(GenreFilms,IDGenreFilms)
SI HNbEnr(GenreFilms) <> 0 ALORS
MessageDvd = " Importation de votre liste des Genres Dvd "
SI OuiNon(MessageDvd) = Non ALORS
RETOUR
SINON
Indice est un entier
Resultat est une chaîne

HGèreIntégrité(Faux)
Indice = fOuvre("C:\Mes Projets\Mes Films\Exe\Liste des Genre Dvd.txt",foLecture)
SI Indice <> -1 ALORS
Resultat = fLitLigne(Indice)
TANTQUE Resultat <> EOT
GenreFilms.Genre = ExtraitChaîne(Resultat,1)
HAjoute(GenreFilms)
SI HErreurDoublon() ALORS
Info("Problème" + SansEspace(GenreFilms.Genre))
FIN
Resultat = fLitLigne(Indice)
Multitâche()
FIN
SINON
Info("Erreur d'ouverture du Fichier : ")
FIN
HGèreIntégrité(Vrai)
Info("Le rapatriement des Genres est terminé.")
TableAffiche(Table,taInit)
FIN
FIN


ou est l'erreur ?
merci de votre aide
Répondre
#2
Salut si ton fichier externe est un fichier de données alors vois aide HdeclareExterne.
Ne craignez pas d'etre lent, craignez juste d'etre a  l'arret.
Coordialement!
Répondre


Sujets apparemment similaires…
Sujet Auteur Réponses Affichages Dernier message
  lecture de fichier dbase devwindiva 4 4,727 20-10-2016, 05:05 PM
Dernier message: TheDuke
  Remplir champs d'un état par programmation à partir d'un composant externe gaymath2 9 5,759 26-05-2015, 01:54 PM
Dernier message: gaymath2
  [RÉSOLU] exporte une table en fichier texte ? Clovis47 6 2,573 22-04-2013, 08:08 AM
Dernier message: Clovis47
  dll externe AMED164 0 1,530 30-05-2009, 02:23 PM
Dernier message: AMED164
  [Résolu] Comment modifier l'état "lecture seule" ? lepirate 1 2,209 02-02-2009, 06:44 PM
Dernier message: lepirate
  Sauvegarde "application externe" veiga 0 1,194 27-08-2008, 09:47 AM
Dernier message: veiga
  Lecture d'un fichier .csv Vanch 2 10,949 11-06-2008, 05:03 PM
Dernier message: Vanch
  Problème de lecture sur table (fichier hyperfile) WindevAmazigh 8 2,452 01-01-2008, 04:00 AM
Dernier message: chonchon
  passage de parametre à un exe externe devwindiva 4 2,302 16-12-2007, 10:28 AM
Dernier message: devwindiva
  Installation sur Disque Dur Externe yohan_titi 8 2,412 29-10-2007, 08:17 AM
Dernier message: Excalibure

Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)