Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
[RÉSOLU]Lister le contenu d'un CD ?
#1
Bonjour à tous, je suis sous windev 10 et je voudrais savoir comment lister le contenu d'un CD en enregistrant ce contenu dans une table !
en fait, ce Cd contient environ 6 films, que je voudrais lister et enregistrer dans une table
je me sers bien de la fonction listefichier, mais si le Cd contient 6 films, cela me copie 6 fois le ,même film ! lol
merci à tous
voici le code d'ouverture du sélecteur qui me permet de sélectionner tous les films présent sur le Cd !
mais cela ne m'en copie qu'un seul !
ensuite le code de la procédure !


SI OuiNon(" Vous allez ajouter des films sans le genre ni le numéro du Cd ... ",...
+ " Vous devrez le faire manuellement !") = Oui ALORS
NbFichierLS est un entier
NbFichierAvi est un entier
CritèreRecherche est une chaîne
ResFichier est une chaîne
NomFilm est une chaîne

NomFilm = fSélecteur("E:\", "", "Sélectionner un fichier",...
"Tous fichiers (*.avi)"+TAB+"*.*", "", fselMulti)

ResFichier = fExtraitChemin(NomFilm, fFichier)
NbFichierAvi = fListeFichier(CritèreRecherche, "AttributFichier", &NbFichierLS)
HLitRecherche(Films,Titre,ResFichier)
SI HTrouve(Films)= Vrai ALORS
Erreur(" Ce Film exisre déjà dans votre Liste et ne peut être ajouté ! " )
TableAffiche(Table,taInit)
RETOUR
FIN
Films.Titre = ResFichier
TableAjouteLigne(Table,Titre)
TableEnregistre(Table)
FIN



PROCEDURE AttributFichier(Repertoire, Nom, Change, NbFichierAvi)
NbFichierLS est un entier
TableAjouteLigne(Table,Nom)
TableEnregistre(Table)
TableAffiche(Table,taCourantPremier)
NbFichierLS++
RENVOYER Vrai


quelqu'un peut il m'aider svp ?
merci
Répondre
#2
Bonjour,

Pour finir tu as quelle version ????

Tu poses la même question dans le forum version 7.5

Il faut choisir une fois pour toute un forum... :roll: :mrgreen:
Se souvenir et savoir sont deux choses différentes. Se souvenir, c'est garder en mémoire. En revanche, savoir signifie assimiler sans dépendre d'un modèle.

WD 4.1 => 23


Répondre
#3
désolé, SamiFred, mais à présent que la version 10 fonctionne, j'en reste à la version 10
Répondre
#4
Merci de ton aide SamiFred
le code que tu m'avais donné fonctionne sous la version 10
Répondre


Sujets apparemment similaires…
Sujet Auteur Réponses Affichages Dernier message
  Lister les dossiers dans une liste calyptusc 4 1,883 29-10-2010, 10:58 PM
Dernier message: calyptusc
  comment lister toutes les base SQLSERVER via windev9 ou 10 hassyah 0 1,306 13-01-2008, 09:52 AM
Dernier message: hassyah
  lister des fichiers hyperfile Guest 6 1,779 11-09-2006, 10:04 AM
Dernier message: nick

Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)