Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
[RÉSOLU]Incrémentation d'un numéro dans une table ?
#1
Bonjour,
j'aimerais savoir comment incrémenter un chiffre dans une table !
je suis sous la version 10
je m'explique...
Mon projet gère la liste de mes films sur Dvd
à chaque insertion d'un Dvd, le numéro change.... en lisant le dernier numéro dans ma table_films, colonne numéro
exemple :
j'insère le Dvd numéro 1, j'aimerais que dans la table_film, la colonne numéro se mette à 1
lors de l'insertion du Dvd suivant,en lisant le dernier numéro dans cette table, que la colonne numéro se mette à 2
et ainsi de suite ! chaque fois que je cliquerais sur le bouton " recherche"
tout en sachant qu'un Dvd comporte 5 à films
cela est il possible ?
merci de votre aide

le code utilisé pour la recherche sur le Dvd est le suivant :

sNomFichier est une chaîne
SI OuiNon(" Vous allez ajouter des films sans le genre... ",...
+ " Vous devrez le faire manuellement !") = Oui ALORS
nNbrFichiers est un entier = fListeFichier("E:\*.AVI","ListeFichiers")
//Appel de la procédure
ListeFichiers(0,sNomFichier)
FIN



PROCEDURE ListeFichiers(Null,gsNomFichier)
HLitRecherchePremier(Films,Titre,gsNomFichier)
SI gsNomFichier <> "" ALORS
SI PAS HTrouve(Films) = Vrai ALORS
Films.Titre = gsNomFichier
Films.Genre = ""
Films.Num_Cd = 1
HAjoute(Films)
TableTrie(Table,"Num_Cd")
SINON
Erreur(" Ce Film exisre déjà dans votre Liste et ne peut être ajouté ! ")
FIN
FIN
TableAffiche(Table)
Répondre
#2
Bonjour,

Pour savoir si un DVD (ou autre) à été insérer dans un lecteur, il faut faire appel à un Timer qui va lancer chaque seconde une procédure et afficher dans une liste les différents disques.

Timer("MesDisques",100,1)


PROCEDURE MesDisques()
// Quel disque est prêt ??
ListeSupprimeTout(Liste1)
i est un entier
POUR i = 65 A 90
SI fDisquePrêt(Caract(i)) = Vrai ALORS ListeAjoute(Liste1,Caract(i)+":\ " + fDisqueInfo(Caract(i),fdNomVolume))
FIN


En général le disque inséré est le dernier de la liste. A ce moment là il est facile d'incrémenter une variable globale au projet lorsque la liste à changé d'occurrence.
Bien sûr ce n'est pas instantané, selon le lecteur il faudra une voir quelques secondes de patience.
Se souvenir et savoir sont deux choses différentes. Se souvenir, c'est garder en mémoire. En revanche, savoir signifie assimiler sans dépendre d'un modèle.

WD 4.1 => 23


Répondre
#3
Bonjour SamiFred et merci de ton aide...
je l'applique de suite
bonne journée
cordialement
Répondre


Sujets apparemment similaires…
Sujet Auteur Réponses Affichages Dernier message
  [RÉSOLU] exporte une table en fichier texte ? Clovis47 6 2,550 22-04-2013, 08:08 AM
Dernier message: Clovis47
  [RÉSOLU]Table et Combo triées ? Clovis47 11 3,356 27-10-2012, 03:43 PM
Dernier message: Clovis47
  [RÉSOLU] ligne de table suivant la date du jour ? Clovis47 2 1,529 25-10-2012, 08:44 AM
Dernier message: Clovis47
  [RÉSOLU]Exportation de table vers texte Clovis47 8 2,895 11-10-2012, 04:46 AM
Dernier message: Clovis47
  affichage de champs numériques wided 3 3,189 16-11-2011, 09:41 PM
Dernier message: TheDuke
  Conversion heure en numérique dimi974 3 2,231 01-02-2009, 05:35 PM
Dernier message: dimi974
  Numéro de serie physique d'une clé USB b_noredine 1 3,836 06-01-2009, 03:24 PM
Dernier message: TheDuke
  Toujours Incrémenter bhdih 3 1,245 28-12-2008, 05:26 PM
Dernier message: Samifred
  NumériqueVersChaîne bhdih 1 1,490 02-12-2008, 06:07 PM
Dernier message: Firetox
  Résolu :Couleur ligne d'une table abdoulay 3 6,136 02-12-2008, 12:59 PM
Dernier message: abdoulay

Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)