Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
Publipostage en Word
#1
Bonjour à tous !

je voudrais utiliser les données d'une table Windev comme source du Publipostage en Word.

Comment faire ?

Merci d'avance.
Répondre
#2
Bonjour,

Jamais fait çà, mais une simple conversion de ta source WD en fichier Excel et le tour est joué !

Bon dev !
Répondre
#3
Il y a plein d'exemples livrés avec windev
WD pilotage de .... etc..
Répondre
#4
Bonjour,

Voila une solution avec les "signets" de Word....


Code :
Ecrire dans un fichier Word (Signet)


   word est un objet Automation dynamique
   word = allouer un objet Automation "Word.application"
   word>>Documents>>Open("C:\test.doc") //Fichier Word concerné
   word>>Visible = Vrai
   j est un entier
   k est un entier = TableOccurrence(TABLE_Pieces)
   POUR j = 1 A k
   TANTQUE j <= k
   TableSelectPlus(TABLE_Pieces,j)
   word>>Selection>>GoTo(-1,0,0,"Numeropiece")    
   word>>selection = TABLE_Pieces.IDPieces_Visitee[j]
   word>>Selection>>GoTo(-1,0,0,"nompiece")
   word>>selection = TABLE_Pieces.Nom_Piece[j]
   word>>Selection>>GoTo(-1,0,0,"etage")
   word>>selection = TABLE_Pieces.Etage[j]
   SI TABLE_Pieces.Visitee = True ALORS
   word>>Selection>>GoTo(-1,0,0,"visiteeoui")
   word>>selection = "X"
   SINON
   word>>Selection>>GoTo(-1,0,0,"visiteenon")
   word>>selection = "X"
   FIN
   word>>Selection>>GoTo(-1,0,0,"justificationtab")
   word>>selection = TABLE_Pieces.Justification[j]
   j++
   FIN
   FIN

Il faut simplement adapter le code selon les besoins de ton application.

Bon dev.
Se souvenir et savoir sont deux choses différentes. Se souvenir, c'est garder en mémoire. En revanche, savoir signifie assimiler sans dépendre d'un modèle.

WD 4.1 => 23


Répondre
#5
Bonjour,

Pour simplement utiliser dans word les données d'une table WD (comme demandé d'ailleurs), la conversion au format Excel est la solution la plus simple et la plus rapide.

Maintenant, être puriste et piloter word avec Windev... c'est le top  Smile

Bon dev, Daniel
Répondre


Sujets apparemment similaires…
Sujet Auteur Réponses Affichages Dernier message
  Word 2013 et ligne de commande jhonis 6 2,377 08-11-2016, 08:12 AM
Dernier message: Madsl@nd
  fermer un fichier Word 2013 jhonis 4 2,535 05-11-2016, 04:22 PM
Dernier message: jhonis
  Ouvrir un modèle word dotx pour du publipostage Jer6464 0 1,956 03-01-2015, 03:11 PM
Dernier message: Jer6464
  Exporter un Etat en Word katikaden 1 2,346 21-08-2014, 06:24 PM
Dernier message: Yusep
  probleme avec insertion d image dans word valdano 0 1,235 12-07-2013, 12:42 AM
Dernier message: valdano
  Remplir un document word Glock19 1 1,877 25-03-2013, 09:28 AM
Dernier message: Samifred
  WD17/AFFICHER WORD AU PREMIER PLAN Jer64 8 2,918 18-03-2013, 07:26 AM
Dernier message: frenchsting
  Publipostage par PDF JAMESDEV 3 1,268 17-12-2012, 01:58 PM
Dernier message: Daniel-Québec
  Publipostage excel karim 3 907 07-12-2012, 03:39 PM
Dernier message: Daniel-Québec
  WD Pilotage Word PetitPoussin 3 3,007 10-05-2011, 10:55 AM
Dernier message: dedale

Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)