Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
Mot de passe pour supprimer un enregistrement
#1
Bonjour
je viens chercher de l'aide
j'ai une fenetre avec 3 Btn ajouter / modifer et supprimer
je veux placer un code dans le bounton supprimer qui demande un mot de passe avant de supprimer un enregistrement

Je compte sur vous
Merci de m'aider d'avance

MERCI
Répondre
#2
Bonjour

Je veux insérer un code pour interdire de supprimer l'enregistrement

voici mon code du bouton supprimer

SI TableOccurrence(Table_Etudiant) = 0 OU Table_Etudiant = -1 ALORS RETOUR
SELON OuiNon("Supprimer cette ligne ?")
CAS Oui
TableSupprime(Table_Etudiant,Table_Etudiant)

CAS Non
RETOUR
FIN
Répondre
#3
Bonjour
j'ai besoin de votre aide SVP

Je veux interdire la suppression de l'enregistrement
ou inserer le code.

SI TableOccurrence(Table_Etudiant) = 0 OU Table_Etudiant = -1 ALORS RETOUR
SELON OuiNon("Supprimer cette ligne ?")
CAS Oui
TableSupprime(Table_Etudiant,Table_Etudiant)

CAS Non
RETOUR
FIN


merci de M'aider
bon dev
Répondre
#4
Depuis 2008 que tu as Windev, tu ne sais toujours pas faire un truc aussi basique ?
si Sai_MDP="toto"
on peut supprimer
sinon
on peu pas
fin
Dans ce cas refait le cours d'autoformation.
Car si quelqu'un te donne la réponse tu n'avanceras jamais.
Répondre
#5
Bonjour
et merci pour ton aide

c'est aussi simple

merci de m'avoir aider


bon dev et bonne fête de PÂQUE
Répondre
#6
wd55 a écrit :Depuis 2008 que tu as Windev, tu ne sais toujours pas faire un truc aussi basique ?
si Sai_MDP="toto"
on peut supprimer
sinon
on peu pas
fin
Dans ce cas refait le cours d'autoformation.
Car si quelqu'un te donne la réponse tu n'avanceras jamais.



Bonjour
s’inscrire et débuter a utiliser windev est très différents

MERCI DE M'AIDER
SI TU LE VEUX
BON DEV
Répondre
#7
Bonjour,

Il faut premièrement enregistrer un mot de passe crypté dans une fichier externe ou HF ou encore dans le registre afin de pouvoir le comparer au moment de la suppression de données.
Ce mot de passe sera déterminé et enregistré par l'administrateur de l'application ou éventuellement par un utilisateur de confiance.

Ensuite il suffit à chaque suppression de lire le mot de passe enregistré et le comparer au mot de passe saisi. Cette comparaison doit être associée à une condition qui va autoriser ou non la suppression des données.

SI <MotDePasseSaisi> = <MotDePasseEnregistré> ALORS
SELON OuiNon("Confirmez-vous la suppression ?")
CAS Non : RETOUR
CAS Oui : //Traitement de suppression
FIN
SINON
Erreur("Mot de passe incorrect !")
FIN



Voilà en gros le plus simple.
Bon dev.
Se souvenir et savoir sont deux choses différentes. Se souvenir, c'est garder en mémoire. En revanche, savoir signifie assimiler sans dépendre d'un modèle.

WD 4.1 => 23


Répondre
#8
Bonjour
Et merci beaucoup Mr Samifred

je tiens encore une deuxieme fois a te remercier
pour la premiere fois que j'ai demande de l'aide sur mon projet etudiant , tu m a vraiment aider
et j'ai bien compris certains processus de programmation de windev
Pour ne pas trop te demander ; je ne comprends pas comment crypter mon mot de passe et faire mot de passe externe

stp donne un exemple
et aide moi a comprend
MERCI DE M'AIDER

Bonne fete de PAQUE
<!-- e --><a href="mailtoConfusediehabib@yahoo.fr">siehabib@yahoo.fr</a><!-- e -->
Répondre
#9
Re..

Regardes ton email <!-- e --><a href="mailtoConfusediehabib@yahoo.fr">siehabib@yahoo.fr</a><!-- e --> tu as une petite fenêtre exemple...

Bon dev.
Se souvenir et savoir sont deux choses différentes. Se souvenir, c'est garder en mémoire. En revanche, savoir signifie assimiler sans dépendre d'un modèle.

WD 4.1 => 23


Répondre
#10
Bonjour Samifred

ET MERCI BEAUCOUP POUR TON AIDE

QUE DIEU TE BENISSE


merci de m'avoir aider
Bon dev
Répondre


Sujets apparemment similaires…
Sujet Auteur Réponses Affichages Dernier message
  comment faire un mot de passe LOUIS_0422 4 2,831 23-06-2011, 12:31 PM
Dernier message: Danone
  Mot de passe Fichier *.fic bil2dz 2 2,599 15-05-2010, 06:44 PM
Dernier message: bil2dz
  Mot passe oublier analyse info_mus2007 1 1,695 17-10-2008, 10:46 PM
Dernier message: Samifred
  changer un mot de passe olilo 7 5,280 05-06-2008, 08:02 AM
Dernier message: COLOMBAT
  [RESOLU] Supprimer un enregistrement d'après sa clé composée jo_la_pasteque 2 3,445 05-05-2008, 11:23 AM
Dernier message: jo_la_pasteque
  Supprimer une valeur d'un Combo arsene12 1 2,855 25-04-2008, 07:17 AM
Dernier message: JR
  bouton modifier , supprimer ,enregistrer kokki 2 8,972 21-04-2008, 10:55 AM
Dernier message: kokki
  Supprimer une ligne dans une combo reliée à un fichier jo_la_pasteque 1 3,087 12-03-2008, 03:19 PM
Dernier message: Samifred
  supprimer une liaison entre deux fenêtres Chatbour 4 2,403 03-03-2008, 05:57 PM
Dernier message: Chatbour
  Requête "supprimer les doublons" arsene12 2 1,606 03-12-2007, 05:36 AM
Dernier message: arsene12

Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)