Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
Echec de connexion à une base de données
#1
J'utilise couramment un logiciel de compta dont je ne peux éditer le code mais dont les bases de données sont aisément ouvertes avec SqliteManager. Je souhaite développer sous Windev 7.5 des modules complémentaires (de ceux offerts par le logiciel pour éditer ces bases). Pour cela il faut passer par la commande SQLConnecte() de Windev 7.5 qui nécessite de définir le nom de la source de données (Data Source Name).
Lorsque je le définis par le nom du fichier à l'aide de fSélecteur() cela ne marche pas
ni en utilisant le type "SQL SERVER" alors que j'ai activé WampServer, ni en utilisant le type "ODBC".
Serait-ce que "Data Source Name" doit être une chaîne différente du chemin long de la base? Je serais bien reconnaissant si quelqu'un pouvait me conseiller. Voici le code défaillant:

NomSource est une chaîne
TypeBase est une chaîne = "ODBC" //"SQL SERVER"//"ORACLE" //
VariableDeTest est une chaîne= "2"
NomSource = fSélecteur("C:\ProgramData\Groupe-Socius\Logeas\base","Choisissez la base","",".S3DB")
NumConnexion = SQLConnecte(NomSource, "", "", "", TypeBase)
SI NumConnexion <> 0 ALORS
SI PAS SQLExec("SELECT * FROM saisie WHERE naturedon="+VariableDeTest,"RECHNATURDON") ALORS
SQLInfoGene("RECHNATURDON")
Erreur("Erreur " + SQL.Erreur + " dans la requête : ", SQL.MesErreur)
FIN
SINON
ch=SQLListeSource("BASE")
ch=RC + Majuscule(SQLListeSource("BASE")) + RC
ch=RC + Majuscule(TypeBase) + RC
SI Position(RC + Majuscule(SQLListeSource("BASE")) + RC, ...
RC + Majuscule(TypeBase) + RC)= 0 ALORS
Erreur("L'accès natif "+TypeBase+" n'est pas correctement installé.",...
"Vérifiez la présence des DLL WinDev correspondantes"+...
"(WDxxxACC.DLL pour Access, WDxxxORA.DLL pour Oracle,"+...
"WDxxxSQS.DLL pour SQL Server)")
SINON
SQLInfoGene()
Erreur("Le type de source de données "+TypeBase+" a bien été trouvé mais la connexion a échoué.",...
"Vérifiez le nom de la base (ou chaîne de connexion) et le mot de passe", SQL.MesErreur)
FIN
FIN
SQLDeconnecte()
Répondre


Sujets apparemment similaires…
Sujet Auteur Réponses Affichages Dernier message
  synchronisation d'une base de donnée Guest 1 1,327 17-04-2004, 07:34 AM
Dernier message: tunidev_mybb_import2
  Récupération d'une base de données Guest 1 1,933 03-02-2004, 11:06 AM
Dernier message: Guest
  connexion à une base access Guest 0 1,619 12-12-2003, 09:53 PM
Dernier message: Guest
  Comment relier une base de données en Windev5.5 à Access?? Guest 2 2,415 18-11-2003, 10:09 AM
Dernier message: Guest

Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)