Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
Corruption d'index HF Classic win7 et SBS2008
#1
Bonjour à tous,

donc voici, il y à quelque temps, nous avons changer nos ordinateur client (windows XP SP3 pour WIndows 7 home premium) et depuis, notre base de donnée HyperFIle Classic ce corrompt régulièrement, avec perte de données.
La base de données est situé sur un serveur windows Windows Server FE Standard, dans u dossier partagé, qui est ensuite associé à un lecteur sur les poste client (Mapped drive)
Aucune modification n'a été apporté à la configuration du serveur qui aurrais pu produire cette situation.

Pour l'instant, j'ai tenté les options suivantes, sans résultats:
- Désactivé le protocol SMBV2 sur le serveur et les postes clients et activé le SMBV1
- Mode compatibilité Windows XP SP3
- Désactivation de la détection automatique réseau (dans les options internet)

Seulement 3 personne utilise un logiciel ce connectant à cette base, avec parfois 2 occurrence du logiciel, donc un maximum de 6 connexions simultanés à la base.

Je crois personnellement qu'il s'agit d'un problème de cache, mais je ne trouve pas la cause même du problème, ni comment le résoudre!

Je vous tient bien entendu au courrant si jamais je trouve une solution à ce problème, car je suis convaincu ne pas être le seul dans cette situation.

Merci d'avance,

Philippe
Répondre
#2
Bonjour,

Alors la première des choses à tenter, à mon avis, serait de désactiver la gestion de l'UAC de Seven sur les postes clients.

Bon courage ! Daniel
Répondre
#3
Quel type de réseau vous utilisez? filaire ou wifi
[url=http://www.freegaza.org/]http://www.freegaza.org/[/url]
Répondre
#4
Bonjour,

merci de vos réponse rapides!

@daniel-Québec: Pour ce qui est de L'UAC, il est déjà désactivé sur l'ensemble des postes utilisateurs .

@Tunidev: Il s'agit d'un réseau filé.

Petit détails supplémentaires: les applications windev sont lancé en mode Administrateur.

Merci encore,

Philippe
Répondre
#5
Bonjour,

Bon... Par contre repasser en SMB V1 te fait plutôt perdre les avantages de la V2, mais encore là ??

La gestion des accès (conflits) est-elle programmée ou WD gère ?

C'est pas évident de trouver le pourquoi...

Bon courage ! Daniel.
Répondre
#6
Bonjour,

@Daniel-Québec : Effectivement, je pers les avantages de la V2, et risque de la repartir, car il semble que le problème soit ailleurs. La gestion des conflit est géré par programmation dans la majorité des cas. Les opération de lecture sont géré par Windev.

J'ai changer le mode de compatibilité de XP SP/ vers XP SP2, et j'ai réussis a tout faire tourné durant 10 jours sans corruption... jusqu'à ce matin, ou un accès Solo (une seul personne connecté au système) à généré une corruption d'index avec perte de donnée (perdu des données entré la journée d'avant).

Étant donnée qu'il s'agit d'une application d'envergure (plus de 50 états, plus de 50 table de base de données, plusieurs dizaine de millier de lignes de code dans 3 projets distincts), il me serais difficile de vérifier l'ensemble des accès BD et de les formatée (avec les accès imbriqué, pas toujours évident).

Donc pour l'instant, je ré-index et va rechercher les information perdu grâce à des copie (shadow Copie), et il semblerais qu'il me fasse effectué ces opération jusqu'au développement de notre nouvelle plateforme (windev 15, qui sera updater en version 19 (quand elle sera sorti) afin d'intégré des application mobile).

Je vais bien entendu continuer de vérifier différente solution au cour du temps, et vous tenir au courant des développement à ce sujet.

Si vous avez des suggestion, n'hésitez pas!!

Merci encore,

Philippe
Répondre
#7
Bonjour,

As-tu remarqué si les corruptions étaient suite à des calculs ??

A+, Daniel.
Répondre
#8
Bonjour,

Nous détectons les corruptions uniquement lors d'un accès subséquent, la plupart du temps en lecture. Il ce peux que la corruption ce produise suite à des calculs, mais nous effectuons toujours les calculs dans des variables local, et non sur le champ de base de donnée directement.

Je vous tiendrai au courant si d'autre solution apparaisse, mais notez que depuis le passage en mode compatibilité SP2 plutôt que SP3, et la diminution des applications multi-instance (2 fois la même application qui roule sur le même PC), 1 seul corruption est survenue (sur 3 semaine de production)... encourageant!

Merci encore, et joyeuse fêtes à tous,

Philippe
Répondre
#9
Salut!

Pas évident ce genre de souci, surtout pour vous qui avez des cheveux :lol:

J'aurais regardé du côté de :

- Réseau
micro coupures? voir également les propriétés la carte réseau du serveur et désactiver le mode économie en passant en veille...

- Type d'accès aux fichiers?
voir du côté accès multiples aux fichiers avec la fonction HModeMulti()
Pensez à passer au système HF/CS beaucoup plus fiable, rapide, sécurisé (pas de partage Windows de la base)

- Il me semble avoir déjà lu également que le système de restauration système de Windows peut être à la base de corruption de fichiers d'index qu'il prend pour des fichiers systèmes! (le désactiver un moment pour test?)
Répondre


Sujets apparemment similaires…
Sujet Auteur Réponses Affichages Dernier message
  Windew4.1 index avec vertion supérieur ouizette 2 3,110 17-04-2015, 05:25 PM
Dernier message: ouizette

Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)