Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
Comptage sur Rubrique Interrupter ....
#1
Bonjour à Toutes et Tous .

Un P'Tit Souci .....

J'ai un Fichier Fic nommé GPWUtilisateur
avec des Rubriques ..... Notamment une de Type Interrupteur nommée Superviseur .....

J' ai un champ de saisie nommé Saisie1 et un Bouton A .

J'aimerais Compter le nombre d' utilisateurs dont la Rubrique Superviseur vaut 1 ( c'est à dire qui sont SUPERVISEUR .... )
Puisque Superviseur vaut 1 ou 0 selon qu'on a le Satut de SUPERVISEUR ou pas .
J'ai mis ce Code dans Bouton A :

Counter est un entier
i est un entier
POUR i=1 A HNbEnr(GPWUtilisateur)
Counter += GPwUtilisateur.Superviseur[i]
FIN
FIN

Alors , ce code marche pas et je ne vois pas pourquoi ???
Merci d'avance pour Votre Aide . Lhassane
Répondre
#2
Bonjour,

Je verrais comme ceci...

Code :
Counter est un entier = 0
POUR TOUT GPWUtilisateur
  SI GPwUtilisateur.Superviseur = 1 ALORS
      Counter++
  FIN
FIN

Cordialement
Se souvenir et savoir sont deux choses différentes. Se souvenir, c'est garder en mémoire. En revanche, savoir signifie assimiler sans dépendre d'un modèle.

WD 4.1 => 23


Répondre
#3
C'est Parfait Samifred ! Cela marche Nickel ....
Grand Merci à Toi et Bon Week-End . Lhassane
Répondre


Sujets apparemment similaires…
Sujet Auteur Réponses Affichages Dernier message
  recherche sur 2 rubrique SALAHdev 1 1,062 06-11-2008, 04:37 PM
Dernier message: gaymath2
  [WD10] Somme d'une rubrique heure en HF wd_newbie 4 2,256 29-10-2008, 07:54 PM
Dernier message: wd_newbie
  comment je peux avoir le total d'une rubrique SALAHdev 1 1,211 09-10-2008, 11:08 PM
Dernier message: ouchehad
  Nbre d'enregistrements d'une rubrique sans doublons arsene12 3 3,148 21-04-2008, 07:06 AM
Dernier message: arsene12
  Comptage arsene12 6 2,739 17-04-2008, 05:59 AM
Dernier message: Ralymba
  [Resolu]Somme de valeurs de rubrique d'un fichier kara 3 4,195 05-03-2008, 11:34 AM
Dernier message: kara
  Ajout d'une rubrique sans écraser la base faithnove 0 1,133 06-02-2008, 02:06 PM
Dernier message: faithnove
  rubrique en arabe judor31 2 1,812 03-01-2008, 09:15 AM
Dernier message: Missoum
  Rubrique de type tableau Missoum 3 1,980 25-06-2007, 05:59 PM
Dernier message: Guest
  [RESOLU]Rubrique type image ElMatador 4 1,302 21-06-2007, 02:26 AM
Dernier message: ElMatador

Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)