Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
Champ Arbre
#1
Bonjour,

J'aurais besoin d'aide pour ajouter les Noeuds fils et les feuilles qui lui sont attachées.

sRacine
     sBrancheType (Noeuds principaux)
               sBrancheFamille (Noeuds fils)
                            sFeuille (Feuilles)

Code :
//// Variables
sRacine est une chaîne = "Toutes"
sBrancheType est une chaîne
sBrancheFamille est une chaîne
sFeuille est une chaîne

// Initialisation
ArbreAjoute(ARBRE_Etiquettes,sRacine,IMG_Dossierracine,IMG_Dossierracine,"0")

// Types de produits
i=0
BOUCLE
    i++
    HLit(FTypesProduits,i)
    SI HEnDehors() ALORS SORTIR
    SI (HEtat()=hEtatActif) ALORS
        // Création du type dans le TreeView
        sBrancheType=SansEspace(FTypesProduits.NomTypeProduit)
        sBrancheFamille=SansEspace(FFamillesProduits.NomFamillesProduits)
        sFeuille=SansEspace(FProduits.Resumenomproduitvaleur)
        ArbreAjoute(ARBRE_Etiquettes,sRacine+TAB+sBrancheType,IMG_Typefermes,IMG_Typeouvert,"G"+FTypesProduits.IDFTypesProduits)
        ArbreDéroule(ARBRE_Etiquettes,sRacine)
        // Recherche des familles de produit affectées à ces types
        HLitRecherche(FFamillesProduits,NomTypeProduit,FTypesProduits.IDFTypesProduits)
        TANTQUE HTrouve()
            ArbreAjoute(ARBRE_Etiquettes,sRacine+TAB+sBrancheType+TAB+sBrancheFamille+TAB+SansEspace(FFamillesProduits.NomFamillesProduits),"P"+FFamillesProduits.IDFFamillesProduits)
            HLitSuivant(FFamillesProduits,NomTypeProduit)
        FIN
    FIN
FIN

J'ai essayé plusieurs configurations mais sans succés.

Merci de votre aide.
Répondre


Sujets apparemment similaires…
Sujet Auteur Réponses Affichages Dernier message
  Champ Arbre couleur d'une ligne iznogood 1 1,275 03-03-2014, 01:25 PM
Dernier message: HRSTECHNOLOGIE
  [Résolu] Images d'un champ Arbre iznogood 4 2,667 24-01-2014, 10:04 AM
Dernier message: iznogood
  Champ arbre par programmation iznogood 1 1,404 04-01-2014, 06:38 PM
Dernier message: jibi049
  MANIPULER CHAMPS ARBRE chaniby 2 1,190 15-11-2011, 10:52 PM
Dernier message: chaniby
  Perte d'identifiant dans un arbre avec le drag and drop Francis D 0 1,065 05-04-2011, 09:25 AM
Dernier message: Francis D
  drag and drop arbre vers table sieben 0 1,230 05-03-2011, 08:26 AM
Dernier message: sieben
  drag and drop arbre vers table sieben 1 1,138 27-02-2011, 06:35 AM
Dernier message: sieben
  MANIPULATION D'UN CHAMP ARBRE molo100 3 1,478 29-04-2010, 03:09 PM
Dernier message: J0r
  LE CHAMP ARBRE molo100 0 911 21-04-2010, 11:18 AM
Dernier message: molo100
  CHAMP ARBRE molo100 0 912 19-04-2010, 09:34 AM
Dernier message: molo100

Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)