Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
Affichage données fichier dans table mémoire
#1
Bonjour,

J'ai besoin de votre aide car je "patauge" vraiment sur mon application...
J'ai créé une table mémoire ou je voudrais afficher 1 ligne de mon fichier à la sélection de ma combo.

Ma combo est remplie par programmation et elle affiche différents produits, quand je sélectionne un produit dans ma combo je voudrais que la valeur s'affiche dans ma table mémoire, et cela pour différentes années.

Ma combo = combo_produits
Ma table mémoire = Table_1

J'ai 4 colonnes dans ma table mémoire, avec : Valeur année 2009, Valeur année 2010, Valeur année 2011, Valeur année 2012

Besoin d'aide please :roll:
Répondre
#2
Bonjour,

Tu as quelle version de Windev... la 10 ou supérieur... ? ou alors tu te trompes de forum...

Pour la combo il faut voir si tu sélectionnes la valeur affichée ou mémorisée (gLien())

Pour la table il faut voir du côté de Tableau croisé dans l'aide et tu crées un état croisé avec l'assistant c'est tout simple.

Bon courage. Windev c'est facile... mais avec le temps.. :mrgreen:
Se souvenir et savoir sont deux choses différentes. Se souvenir, c'est garder en mémoire. En revanche, savoir signifie assimiler sans dépendre d'un modèle.

WD 4.1 => 23


Répondre
#3
Bonjour, j'ai réussi de cette façon là :

Code :
TableSupprimeTout(TABLE_1)
nNNiveau=COMBO_Niveau..ValeurMémorisée


sReqLib="SELECT * FROM PD WHERE IDParamPDM="+nNNiveau

sReqLib+=" ORDER BY DATE, IDCR"

SI PAS HExécuteRequêteSQL(sdReqLib,sReqLib) ALORS
    Erreur(HErreurInfo())
FIN

POUR TOUT sdReqLib
    
    bTrouve=Faux
    nNocc=TABLE_1..Occurrence
    POUR i = 1 A nNocc
        SI sdReqLib.IDCR=TABLE_1.COL_CA[i] ALORS
            bTrouve=Vrai    
            SORTIR
        FIN
        
    FIN
        SI bTrouve= Faux ALORS         
            TableAjoute(TABLE_1)
            TableSelectPlus(TABLE_1,TableOccurrence(TABLE_1))
            TABLE_1.COL_CA=sdReqLib.IDCR
            i=TableOccurrence(TABLE_1)
        FIN
    
    
    SELON sdReqLib.Date..Année
        CAS 2009 :
            TABLE_1.COL_2009[i]=sdReqLib.Mnt_CR
            
            
        CAS 2010 :
            TABLE_1.COL_2010[i]=sdReqLib.Mnt_CR
            
        CAS 2011 :
            TABLE_1.COL_2011[i]=sdReqLib.Mnt_CR

        CAS 2012 :
            TABLE_1.COL_2012[i]=sdReqLib.Mnt_CR

        CAS 2013 :
            TABLE_1.COL_2013[i]=sdReqLib.Mnt_CR

            
        AUTRE CAS : Info("Année non existante")
            
    FIN
    
FIN

HLibèreRequête(sReqLib)
Répondre


Sujets apparemment similaires…
Sujet Auteur Réponses Affichages Dernier message
  Recherche dans Table Mémoire .... BOURBAKI 5 3,987 05-05-2014, 07:50 PM
Dernier message: BOURBAKI
  Affichage de tous les donnes sur ma table faloudja 13 4,734 20-04-2013, 10:14 AM
Dernier message: faloudja
  Affichage des données dans une table Tarcicius 2 2,191 05-10-2012, 05:12 AM
Dernier message: a3xxx
  affichage des données dans des champs text+windev 10 hiker80 1 1,643 13-05-2011, 06:54 AM
Dernier message: Samifred
  recuperer les données d'une ligne de la table hiker80 2 3,887 28-03-2011, 10:18 AM
Dernier message: Samifred
  Données RTF dans un etat sarbatis 1 1,695 26-08-2010, 08:57 PM
Dernier message: tunidev_mybb_import2
  enregistrement d'une table mémoire contenu dans une fenetre mirouxmmp111 7 3,138 17-08-2010, 10:19 PM
Dernier message: emidev
  sommation de colonne d'un table mémoire mirouxmmp111 3 1,413 06-08-2010, 07:35 PM
Dernier message: mirouxmmp111
  combo base de données access dans windev BIROSALAME 0 1,768 05-08-2010, 11:26 AM
Dernier message: BIROSALAME
  [RESOLU] La commande HFILTRE sur table mémoire? JAMESDEV 1 2,363 16-04-2010, 01:01 PM
Dernier message: JAMESDEV

Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)