Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
[ABANDONNÉ EN VERSION 7]
#1
Bonjour à tous, je suis sous windev 7 et je voudrais savoir comment lister le contenu d'un CD en enregistrant ce contenu dans une table !
en fait, ce Cd contient environ 6 films, que je voudrais lister et enregistrer dans une table
je me sers bien de la fonction listefichier, mais si le Cd contient 6 films, cela me copie 6 fois le ,même film ! lol
merci à tous
Répondre
#2
Bonjour,

Quel code utilises-tu ?

Tu peux le publier !
Se souvenir et savoir sont deux choses différentes. Se souvenir, c'est garder en mémoire. En revanche, savoir signifie assimiler sans dépendre d'un modèle.

WD 4.1 => 23


Répondre
#3
le code que j'utilise est grosso modo le code fourni par l'exemple de windev 7
je te le joins ci après.... mais je n'arrive pas à le mettre comme il faut !

SI OuiNon(" Vous allez ajouter des films sans le genre... ",...
+ " Vous devrez le faire manuellement !") = Oui ALORS
NbFichierLS est un entier
NbFichierAvi est un entier
CritèreRecherche est une chaîne
NomFichier est une chaîne
CritèreRecherche = fRepSélecteur("E:\", "Sélectionner un répertoire",...
"Recherche des .Avi dans le répertoire sélectionné")
SI CritèreRecherche = "" ALORS RETOUR
CritèreRecherche = CritèreRecherche + "*.avi"
NbFichierAvi = fListeFichier(CritèreRecherche, "AttributFichier", &NbFichierLS)
NbFichierAvi++
SINON
RETOUR
FIN



PROCEDURE AttributFichier(Repertoire, Nom, Change, NbFichierAvi)
NbFichierLS est un entier
TableAjouteLigne(Table,Nom)
TableEnregistre(Table)
TableAffiche(Table,taCourantPremier)
NbFichierLS++
RENVOYER Vrai
Répondre
#4
Re..

Et bien chez-moi ça fonctionne parfaitement...

Tous les fichiers sont listés... quelque soit l'extension.
Se souvenir et savoir sont deux choses différentes. Se souvenir, c'est garder en mémoire. En revanche, savoir signifie assimiler sans dépendre d'un modèle.

WD 4.1 => 23


Répondre
#5
alors là, il y a un truc que je ne comprends pas ! moi il ne prend que le premier titre, et s'il y a 6 films sur le cd, il me le copie 6 fois !
Répondre
#6
Alors le problème est ailleurs, mon cher... tu as essayé un autre CD !
Se souvenir et savoir sont deux choses différentes. Se souvenir, c'est garder en mémoire. En revanche, savoir signifie assimiler sans dépendre d'un modèle.

WD 4.1 => 23


Répondre
#7
SamiFred, tu me dis que ce code fonctionne chez toi ?
je viens de mettre un autre disque , et en fait, je viens de m'apercevoir que mon code n'est pas bon !
il me lit la première ligne de ma table, et me la recopie autant de fois qu'il trouve de film sur le cd, mais ne me copie pas le contenu du cd !
y a un truc que je ne comprends pas du tout !
j'ai changé mon code.....
de cette manière cela fonctionne, mais je ne peux ajouter qu'un seul film à la fois!
si je sélectionne les 6 en une seule fois, il ne m'en ajoute qu'un seul !
de l'aide svp ! merci

  • [/list:u]
    SI OuiNon(" Vous allez ajouter des films sans le genre... ",...
    + " Vous devrez le faire manuellement !") = Oui ALORS
    NbFichierLS est un entier
    NbFichierAvi est un entier
    CritèreRecherche est une chaîne
    ResFichier est une chaîne
    CheminFichier est une chaîne

    CheminFichier = fSélecteur("E:\", "", "Sélectionner un fichier",...
    "Tous fichiers (*.avi)"+TAB+"*.*", "", fselMulti)

    ResFichier = fExtraitChemin(CheminFichier, fFichier)
    NbFichierAvi = fListeFichier(CritèreRecherche, "AttributFichier", &NbFichierLS)
    HLitRecherche(Films,Titre,ResFichier)
    SI HTrouve(Films)= Vrai ALORS
    Erreur(" Ce Film exisre déjà dans votre Liste et ne peut être ajouté ! " )
    Titre = ""
    TableAffiche(Table,taInit)
    RETOUR
    FIN
    Titre = ResFichier
    Films.Titre = ResFichier
    TableAjouteLigne(Table,Titre)
    TableEnregistre(Table)
    FIN
Répondre
#8
Bonjour,

Essayes comme ceci... (c'est le code principal)

//Code bouton (ou autre)
Code :
sNomFichier est une chaîne
nNbrFichiers est un entier = fListeFichier("E:\*.AVI","ListeFichiers")
//Appel de la procédure
ListeFichiers(0,sNomFichier)

//Procédure
Code :
PROCEDURE ListeFichiers(null,gsNomFichier)
HLitRecherchePremier(Films,Nom,gsNomFichier)
SI gsNomFichier <> "" ALORS
    SI PAS HTrouve(Films) = Vrai ALORS
        Films.Nom = gsNomFichier
        HAjoute(Films)
    FIN    
FIN    
TableAffiche(Table1)

C'est très rapide et tu peux ensuite saisir dans la table et ou encore faire d'autres conditions dans la procédure.
Se souvenir et savoir sont deux choses différentes. Se souvenir, c'est garder en mémoire. En revanche, savoir signifie assimiler sans dépendre d'un modèle.

WD 4.1 => 23


Répondre
#9
bonjour, tu me mets ceci :

sNomFichier est une chaîne
nNbrFichiers est un entier = fListeFichier("E:\*.AVI","ListeFichiers")
//Appel de la procédure
ListeFichiers(0,sNomFichier)

mais je ne peux appeler cette procédure de cette manière !
ne dois je pas la mettre entre "" ?
sinon elle n'est pas reconnue !
Répondre
#10
je ne comprends pas le message d'erreur !
lors de l'appel de la procédure on me dit que l'on attendait 2 paramètres et que l'on en reçoit 4 !
j'y comprends plus rien !
Répondre


Sujets apparemment similaires…
Sujet Auteur Réponses Affichages Dernier message
  ce fichier est trop ancien ( version 4.1) ouizette 0 1,629 20-08-2008, 01:56 PM
Dernier message: ouizette
  Vente une version complète Windev 5 Guest 0 7,463 26-10-2006, 10:58 AM
Dernier message: Guest
  Version client ! Guest 3 1,645 26-06-2004, 09:46 AM
Dernier message: tunidev_mybb_import2
  Nouvelle version de windev tunidev_mybb_import2 0 1,705 12-09-2003, 05:29 PM
Dernier message: tunidev_mybb_import2

Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)